3

So after the update to Windows 10, everything with my texmaker-miktex install was fine until a catastrophic crash meant I had to fresh install eveything. Now I'm getting:

"Could not start the command. pdflatex -synctex=1 -interaction=nonstopmode %.tex"

whenever I try to compile. I've installed and re-installed miktex and texmaker (both 32 and 64 bit versions, in all permutations), checked that the pdflatex path is there and correct (cmd -> pdflatex returns "This is pdfTeX, Version 3.1 yadda yadda yadda), I've tried freeing up permission in my MikTeX folder and nothing has worked.

Anyone got any ideas?

  • Try another editor, e.g. texstudio or the included texworks. – Ulrike Fischer Aug 6 '15 at 19:55
  • Have you tried adding the full path in the texmaker conf? – daleif Aug 6 '15 at 20:18
  • Full path just threw up the same error, but with the full path. I think it's a permissions thing(?) Texstudio just comes up with a similar message, and TeXnicCenter comes out with a memory dump file not found. It's just full access to my MiKTeX folder that I need right? – Ross Aug 6 '15 at 22:09
  • I've switched every folder with MiKTeX in the name over to full control permission, with no luck. – Ross Aug 6 '15 at 22:34
  • Can you run a small hello world example from the command line with pdflatex? – Ulrike Fischer Aug 7 '15 at 6:48
2

I was having the exact same problem but then I updated MikTeX on my computer as an Admin and everything's been working fine since. You can find out how to update here if you're not sure http://miktex.org/howto/update-miktex

hope it works out for you :)

  • 1
    Wow! Just wow. Thanks so much!!! I'd given up on it for now and had been using my old laptop. Simple when you know how, huh? :D – Ross Aug 10 '15 at 9:07
2

I had problems reinstalling Miktex 2.9 on Windows 10 after uninstalling it.

I tried several things, so I want to share how I finally solved it and what the problem was.

The problem was that Miktex had not completely been removed from the computer, there were remains of the program in the local appdata folder Open your File Explorer and type %localappdata% in the address bar. This will take you to the local application settings folder.

After doing that I could install Miktex 2.9 normally again.

Hope that helps somebody.

  • Maybe using some cleaning tool (like Ccleaner) or specialized unistalling software (like Revo) can be of service as well. – Guilherme Zanotelli Jan 10 '17 at 10:33

protected by diabonas Sep 28 '17 at 14:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.