1

I have a little problem with SumatraPDF inverse search. I followed this post for configuration. When I click "view output", Sumatra shows my PDF (which is a good start), but when I click on a word in the PDF to use the inverse search feature, it opens a new instance of TexnicCenter. Does someone know how to solve this? It should be a character to change in the command line but I can't figure it out.

I am using TexnicCenter 2.0 Beta 1 and Sumatra 3.0 and my command line is :

"C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe" -inverse-search "\"C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe"\ /ddecmd \"[goto('%f','%l')]\""

By the way, I tried to modify Windows 7 registry according to this post and it does not solve the problem.

2

You have an error in your command line. The \ after TeXnicCenter.exe has to be before ". So please correct the call for SumatraPDF to:

C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\""

With the current versions of SumatraPDF (version 3.0) and TeXnicCenter (version 2.2) the inverse search runs like a charm.

If you have installed the 64 bit version of TeXnicCenter please change C:\Program Files (x86)\TeXnicCenter to C:\Program Files\TeXnicCenter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.