3

I fail to get Lualatex to properly typeset punctuation marks for French when using the classes standalone or dinbrief. In this minimal example I would expect to see spaces before the colon and before the exclamation mark. Altering the document class to article I do get the expected behavior.

\documentclass{standalone}

\usepackage{fontspec, polyglossia}
\setdefaultlanguage{french}

\begin{document}
   \today{} here: should have been a space before those two dots!
\end{document}

enter image description here

How could I enforce these spaces? I'm less worried about standalone, but given the issue in dinbrief and possibly a number of other document classes this would be nice to be able to do.

Thanks for your hints.

Bastian

  • 1
    And a small space before the ! ! – Tarass Aug 7 '15 at 9:12
  • 3
    Bug in standalone, I'd say. – egreg Aug 7 '15 at 9:35
  • 1
    If I change standalone into dinbrief, I get the spaces. – egreg Aug 7 '15 at 9:49
4

Imho it is a problem of the implementation in polyglossia: the space is lost inside some boxes:

\documentclass{article}

\usepackage{fontspec, polyglossia}
\setdefaultlanguage{french}

\begin{document}

   \begin{tabular}{l}
   \today{} here: should have been a space before those two dots!
   \end{tabular}

   \mbox{\today{} here: should have been a space before those two dots!}

\end{document}

enter image description here

Probably you are using it in dinbrief in a place where such boxes are involved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.