2

I write a simple file (T.tex):

% T.tex
\documentclass{paper}

\newfont{\dviiseg}{d7seg scaled 1200}

\begin{document}
    $\mbox{\dviiseg{c}}(c)$
\end{document}

then I put the d7seg.mf to the current directory. but miktex-mf.exe says:

Running miktex-mf.exe...

This is METAFONT, Version 2.718281 (MiKTeX 2.9)
! I can't find file `d7seg'.
 ... \mag:=magstep(1.0);nonstopmode;input d7seg

Please type another input file name

! Emergency stop.

 ... \mag:=magstep(1.0);nonstopmode;input d7seg

Transcript written on mfput.log.

My os is win7, and T.tex can not obtain output.

BTW: When I run it in my laptop(XP + MikTeX 2.7), T.tex can obtain output pdf file.

1

Yes look as if the current directory is not searched. Put your mf in a local texmf tree in fonts\source.

  • Maybe my MikTeX has problem. If I copy d7seg.pk to the current directory, this problem is solved. And today I change to TeXLive 2011, this problem is also solved. I donot know why. – Xie Xie Aug 18 '11 at 6:09
  • 1
    Well obviously miktex doesn't search the current directory for mf.files. This could be deliberate (e.g. for security) or simply a bug: Make a bug report then you will get an explanation. Apart this: It is much better to put mf files in the correct directory in a local tree. And using pk-files is not a good idea, the resolution could be wrong. – Ulrike Fischer Aug 18 '11 at 7:48
  • I mean, when I uses TeXLive2011 and the current directory only include d7seg.mf, my tex file can work well. And METAFONT will generate d7seg.pk720 automatically. – Xie Xie Aug 18 '11 at 9:29
  • I know what you mean. It doesn't work like this in the current miktex. You must put the mf in a texmf tree. – Ulrike Fischer Aug 18 '11 at 9:42
  • 2
    I did test it in miktex. It doesn't work. I made a bug report. sourceforge.net/tracker/… – Ulrike Fischer Aug 18 '11 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.