4

The tips of the red arrows are not visible, how can that they be ?

\documentclass{standalone}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{tikz}
\usetikzlibrary[arrows.meta,bending]
\usetikzlibrary{positioning}
\begin{document}
\begin{tikzpicture}[>=stealth]
\coordinate [label=-90:$A$]  (A) at (0,0)  ;
     \coordinate [label=90:$B$ ]  (B) at (2,4) ;
     \coordinate [label=-90:$C$]  (C) at (6,1) ;
     \coordinate [label=90:$D$ ]  (D) at (8,5) ;
     \draw[->,red] (A) to [bend left] node [midway,above]{$A$ est transformé  en $B$} (B) ;
     \draw[->,red] (C) to [bend right] node [midway,above]{$C$ est  transformé  en $D$} (D) ;
     \draw [->,very thick](A) -- (B) ;
     \draw [->,very thick](C) -- (D) ;
     \draw [dashed] (B) -- (C) ;
     \draw [dashed] (A) -- (D) ;
     \draw (A) -- (C) ;
     \draw (B) -- (D) ;
\end{tikzpicture}
\end{document} 

enter image description here

1 Answer 1

3

One option is to use shorten >= and/or increase the value for the bend options:

\documentclass{standalone}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{tikz}
\usetikzlibrary[arrows.meta,bending]
\usetikzlibrary{positioning}
\begin{document}
\begin{tikzpicture}[>=stealth,redarr/.style={->,red,shorten >= 3pt}]
\coordinate [label=-90:$A$]  (A) at (0,0)  ;
     \coordinate [label=90:$B$ ]  (B) at (2,4) ;
     \coordinate [label=-90:$C$]  (C) at (6,1) ;
     \coordinate [label=90:$D$ ]  (D) at (8,5) ;
     \draw[redarr] (A) to [bend left=50] node [midway,above]{$A$ est transformé  en $B$} (B) ;
     \draw[redarr] (C) to [bend right=50] node [midway,above]{$C$ est  transformé  en $D$} (D) ;
     \draw [->,very thick](A) -- (B) ;
     \draw [->,very thick](C) -- (D) ;
     \draw [dashed] (B) -- (C) ;
     \draw [dashed] (A) -- (D) ;
     \draw (A) -- (C) ;
     \draw (B) -- (D) ;
\end{tikzpicture}
\end{document} 

enter image description here

Another one is to use in=, out= angles; I also changed the anchors for the nodes with text to avoid overlapping:

\documentclass{standalone}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{tikz}
\usetikzlibrary[arrows.meta,bending]
\usetikzlibrary{positioning}
\begin{document}
\begin{tikzpicture}[>=stealth,redarr/.style={->,red,shorten >= 3pt}]
\coordinate [label=-90:$A$]  (A) at (0,0)  ;
     \coordinate [label=90:$B$ ]  (B) at (2,4) ;
     \coordinate [label=-90:$C$]  (C) at (6,1) ;
     \coordinate [label=90:$D$ ]  (D) at (8,5) ;
     \draw[redarr] (A) to [out=120,in=180] node [midway,above,anchor=east,align=center]{$A$ est transformé \\  en $B$} (B) ;
     \draw[redarr] (C) to [out=10,in=0] node [midway,anchor=west,align=center]{\ $C$ est  transformé  \\ en $D$} (D) ;
     \draw [->,very thick](A) -- (B) ;
     \draw [->,very thick](C) -- (D) ;
     \draw [dashed] (B) -- (C) ;
     \draw [dashed] (A) -- (D) ;
     \draw (A) -- (C) ;
     \draw (B) -- (D) ;
\end{tikzpicture}
\end{document}

enter image description here

4
  • Thank you, that's what I wanted to do. Perhaps can we improve the text position on the arcs ?
    – Fabrice
    Aug 10, 2015 at 16:32
  • @Fabrice You're welcome. Yes, it can be improved. Give me some seconds. Aug 10, 2015 at 16:48
  • 1
    @Fabrice Please see my updated answer. I think it looks better now, but adjust the settings according to your needs. Aug 10, 2015 at 16:55
  • It's perfect, thank you again for your help.
    – Fabrice
    Aug 10, 2015 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .