6

I'm using BibLaTeX-apa to cite references, but I'm having trouble getting a citation to print out (, ) when I reference to it in the main text. I'm using the \parencite command as is advised on the first page of the biblatex-apa-test documentation and what I get is ( ), that is, without the comma.

I've been trying to write a minimal example but I haven't figured out how to create database within the document so the example I provide uses my own database.

\documentclass{article}
\usepackage[bibstyle=apa, style=authoryear]{biblatex}
\usepackage[american]{babel}
\usepackage{csquotes}
\DeclareLanguageMapping{american}{american-apa}
\addbibresource{/library.bib}
\begin{document}
Test \parencite{Lamme2006}.
\printbibliography
\end{document}

1 Answer 1

7

Styles are applied in the order they are set. Looks like you want apa for both the bibliography and citation styles so just use style=apa instead of bibstyle=apa,style=authoryear.

For reference, you can use different styles in the same document. Some more information can be found in this question.

7
  • Thanks for the suggestion. Same problem though.
    – Speldosa
    Aug 19, 2011 at 15:38
  • @Speldosa style sets both the citation and bibliography styles. Why not just use style=apa instead of bibstyle=apa, style=authoryear?
    – Audrey
    Aug 19, 2011 at 15:59
  • Actually I've always used style=apa to set both bibstyle and citestyle to apa. I'd always get the comma that way.
    – imnothere
    Aug 19, 2011 at 15:59
  • @LianTze The styles are applied in the order they are specified. So setting style=authoryear afterward undoes the edit you suggested.
    – Audrey
    Aug 19, 2011 at 16:05
  • 1
    @LianTze Can you edit your post? I think it had the right idea, and I'd prefer not to add another answer. UPDATE: Nevermind. My changes were approved. Please feel free to edit it further.
    – Audrey
    Aug 19, 2011 at 21:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .