2

I am trying to compile a template provided in JACS website by Joseph Wright. Although it is compiled w/o any error (if I exclude the package mhchem), when I add my .bib file, I have an error message saying that ! Paragraph ended before \@BOOKMARK was complete. Would you have any suggestion about my problem? Here is the document from the template: test.tex

\documentclass[journal=jacsat,manuscript=article]{achemso}

%\usepackage[version=3]{mhchem}
\usepackage[T1]{fontenc}      
\usepackage{array}
\usepackage{booktabs}
\usepackage{hypdoc}
\usepackage{listings}
\usepackage{lmodern}
\usepackage{mathpazo}
\usepackage{microtype}
\usepackage{caption}
\usepackage{float}
\usepackage{geometry}
\usepackage{natbib}
\usepackage{setspace}
\usepackage{xkeyval}
\usepackage{amsmath}
%%%%%%%%%%%%%%%%%%
\title {\bf Synergistic effect in the co-assembly of type-I and type-III
  collagens}

\begin{document}
\section{Introduction}
co-fibril of type-I/III\\
 \cite{silver84}: monomer lengths Table 1 - fix author names\\
\cite{romanic91}: type-III co-assembles with type-I and makes fibrils 
   thinner.\\
\bigskip

\bibliography{achemso-demo}
\end{document}

My bib file is: test.bib

@article{silver84,
  title={Molecular structure of collagen in solution: comparison of types {I}, {II}, {III} and {V}},
  author={Silver, F H and Birk, D E},
  journal={Int. J. Biol. Macromol.},
  volume={6},
  number={3},
  pages={125--132},
  year={1984},
  publisher={Elsevier}
}
@article{romanic91,
  title={Copolymerization of p{N}collagen {III} and collagen {I}. p{N}collagen {III} decreases the rate of incorporation of collagen {I} into fibrils, the amount of collagen {I} incorporated, and the diameter of the fibrils formed.},
  author={Romanic, A M and Adachi, E and Kadler, K E and Hojima, Y and Prockop, D J},
  journal={J. Biol. Chem.},
  volume={266},
  number={19},
  pages={12703--12709},
  year={1991},
  publisher={ASBMB}
}
  • Off-topic: never use \bf in a LaTeX document - it was obsolete 20 years ago. But you shouldn't have manual markup in the argument to something like \title anyway... – cfr Aug 16 '15 at 21:05
2

I get no error if I load hyperref instead of hypdoc (that's an addition relative to the doc package, which is out of place here). Also you shouldn't use geometry and setspace, as the class already takes care of the pagination settings. Loading lmodern is useless if you later load mathpazo. You don't need xkeyval, which is a helper package for other packages, nor natbib that's already loaded by the class.

Note that hyperref should be loaded last, with the choice of packages you have.

Avoid explicit markup such as \bf (which, by the way, is an obsolete command) in \title: the class already does the desired thing.

\begin{filecontents*}{\jobname.bib}
@article{silver84,
  title={Molecular structure of collagen in solution: comparison of types {I}, {II}, {III} and {V}},
  author={Silver, F H and Birk, D E},
  journal={Int. J. Biol. Macromol.},
  volume={6},
  number={3},
  pages={125--132},
  year={1984},
  publisher={Elsevier}
}
@article{romanic91,
  title={Copolymerization of p{N}collagen {III} and collagen {I}. p{N}collagen {III} decreases the rate of incorporation of collagen {I} into fibrils, the amount of collagen {I} incorporated, and the diameter of the fibrils formed.},
  author={Romanic, A M and Adachi, E and Kadler, K E and Hojima, Y and Prockop, D J},
  journal={J. Biol. Chem.},
  volume={266},
  number={19},
  pages={12703--12709},
  year={1991},
  publisher={ASBMB}
}
\end{filecontents*}

\documentclass[journal=jacsat,manuscript=article]{achemso}
\usepackage[T1]{fontenc}      

\usepackage[version=3]{mhchem}
\usepackage{array}
\usepackage{booktabs}
\usepackage{listings}
\usepackage{mathpazo}
\usepackage{microtype}
\usepackage{caption}
\usepackage{float}
\usepackage{amsmath}
\usepackage{hyperref}

%%%%%%%%%%%%%%%%%%
\title {Synergistic effect in the co-assembly of type-I and type-III
  collagens}

\begin{document}
\section{Introduction}
co-fibril of type-I/III

\cite{silver84}: monomer lengths Table 1 - fix author names

\cite{romanic91}: type-III co-assembles with type-I and makes fibrils 
   thinner.

\bibliography{\jobname}
\end{document}

In the example I use filecontents just for making it self-contained; use your bib file name instead of \jobname in the argument to \bibliography.

enter image description here

  • @cfr Right. Removed. – egreg Aug 16 '15 at 21:26
  • Can't upvote twice... ;). – cfr Aug 16 '15 at 21:27
  • @egreg, Thanks very much for your informative answer. 'chemgreek' file is still causing error, but since I do not really need that, my document is compiled w/o any error now!. – Esma Eryilmaz Aug 17 '15 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.