4

I am using fancyhdr to create a short running title for an article I'm drafting. I also need my tables and figures to be printed after the bibliography upon submission to the journal. Initially, the running title works how I want it to by printing in the top right portion of the page. However, after I use the command to print the bibliography, the running title is altered and includes "References" on the top left portion of the page, as well as the header that I actually want. After the bibliography, subsequent pages continue to include "References" in the running title. How do I remove "References" from the running title? (I don't want "References" to appear in the running title for any pages).

MWE:

\documentclass[twocolumn]{article}
\usepackage[style=authoryear,maxcitenames = 2,mincitenames = 1,maxbibnames = 99,minbibnames = 1,dashed = false,firstinits=true,backend=biber]{biblatex}  
% !BIB TS-program = biber     
%^ line above is necessary to tell TeXShop to use Biblatex rathern than traditional BibTex.
\usepackage[utf8]{inputenc}    % utf8 support       
\usepackage[T1]{fontenc}       % code for pdf file  % w/out these two lines, I get the warning, "WARN - The entry '_______' has characters which cannot be encoded in 'ascii'. Recoding problematic characters into macros.
\usepackage{fancyhdr}

\usepackage{filecontents}
\begin{filecontents}{Test.bib}    
@unpublished{usgs_gmted_data,
Author = {{United States Geological Survey}},
Title = {USGS Global Multi-resolution Terrain Elevation Data (GMTED) product},
Url = {http://topotools.cr.usgs.gov/gmted_viewer/},
urldate = {2013-09-01}, 
urlmonth = {September},                                                    
Year = {2010}}
\end{filecontents}
\addbibresource{Test.bib}


\renewcommand\headrulewidth{0pt}    % No line under running header
\pagestyle{fancy}
\rhead[R]{my running header}


\begin{document}
abc
\newpage
\nocite{*}
\newpage
abc
\printbibliography
\newpage
abc
\end{document} 
3

Under your settings, the bibliography is printed as a \section, which naturally updates the header content using \markboth. You can set \markboth to gobble its arguments temporarily, which would therefore not affect the header:

{\renewcommand{\markboth}[2]{}% Remove header adjustment
\printbibliography}

Here is your minimal example:

enter image description here

\documentclass[twocolumn]{article}
\usepackage[style=authoryear,maxcitenames = 2,mincitenames = 1,maxbibnames = 99,minbibnames = 1,dashed = false,firstinits=true,backend=biber]{biblatex}  
% !BIB TS-program = biber     
%^ line above is necessary to tell TeXShop to use Biblatex rathern than traditional BibTex.
\usepackage[utf8]{inputenc}    % utf8 support       
\usepackage[T1]{fontenc}       % code for pdf file  % w/out these two lines, I get the warning, "WARN - The entry '_______' has characters which cannot be encoded in 'ascii'. Recoding problematic characters into macros.
\usepackage{fancyhdr}

\usepackage{filecontents}
\begin{filecontents}{Test.bib}    
@unpublished{usgs_gmted_data,
Author = {{United States Geological Survey}},
Title = {USGS Global Multi-resolution Terrain Elevation Data (GMTED) product},
Url = {http://topotools.cr.usgs.gov/gmted_viewer/},
urldate = {2013-09-01}, 
urlmonth = {September},                                                    
Year = {2010}}
\end{filecontents}
\addbibresource{Test.bib}

\renewcommand\headrulewidth{0pt}    % No line under running header
\pagestyle{fancy}
\rhead[R]{my running header}

\begin{document}
abc
\newpage
\nocite{*}
\newpage
abc
{\renewcommand{\markboth}[2]{}% Remove header adjustment
\printbibliography}
\newpage
abc
\end{document} 
  • I did this, and after Texstudio asked to change something about my command \printbibliography command the file stopped compiling. The line !BIB TS-program = biber was messing everything up. – Austin Downey Oct 30 '17 at 7:51
0

A simple way to work around this problem is to simply define the header for either the entire document or just the pages of interest as an empty header. Here is a MWE of how I did this:

\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyhead[RE,RO]{}
\fancyhead[LE,LO]{}

I simply placed these lines in the preamble and successfully removed the reference headers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.