2

While the following works in the article class:

\documentclass{article}
\usepackage{hyperref}
\hypersetup{colorlinks = false, urlbordercolor = {0 1 0}}
\begin{document}
    \href{https://www.google.com/}{Google}
\end{document}

enter image description here

It does not with the beamer class:

\documentclass{beamer}
\hypersetup{colorlinks = false, urlbordercolor = {0 1 0}}
\begin{document}
\begin{frame}
    \href{https://www.google.com/}{Google}
\end{frame}
\end{document}

enter image description here

How can I get the same result with beamer as I do with article?

1 Answer 1

5

The border can be enabled by option pdfborder. The third number is the border thickness. Since the navigation elements should probably not have borders, the example sets the border in the frame only:

\documentclass{beamer}
\hypersetup{
  urlbordercolor = {0 1 0},
}
\begin{document}
\makeatletter
\begin{frame}
  \hypersetup{pdfborder={0 0 1}}
  \href{https://www.google.com/}{Google}
\end{frame}
\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .