Win7 64b - TexStudio 2.9.4 - Miktex


Bibtex does not find *.aux file when I export my auxiliary files into a different directory, e.g. /auxiliary.

With current folder structure:

root/ |_ main.tex |_ bibliography.bib |_ auxiliary/ |_ *aux |_ ...

PS. This solution is related to Texstudio + Biber + build folder but different enough to provide exact settings here. Also, closely related to How can Bibtex find the auxiliary files it needs when these are stored in a subdirectory?

2 Answers 2


Assuming the folder structure in the question, you should have the following configs.

Under Options > Configure TexStudio ...> Commands

  • PdfLatex: pdflatex.exe -synctex=1 -interaction=nonstopmode %.tex -aux-directory=./auxiliary/
  • BibTex: bibtex.exe ./auxiliary/%

Under Options > Configure TexStudio ...> Build (after you checked Show Advanced Options on the bottom-left corner):

  • Add ./auxiliary/ into the Log File text-box in the lower pane with the Build Options.

Note: this does not work if you use external applications such as gnuplot. The external application won't be able to find the required build files now present outside of the root directory.

  • As of TexStudio 2.11 Options > Configure TexStudio ...> Build doesn't have any Log File option.
    – Desik
    Commented Aug 21, 2016 at 18:32
  • 3
    @Desik You need to tick the advanced options.
    – Oleg
    Commented Nov 29, 2016 at 22:29

Just if anyone needs the same under Linux, the option for PdfLatex has different name in TeXLive. Under Options > Configure TexStudio ...> Commands for PdfLatex one should put:

pdflatex -synctex=1 -interaction=nonstopmode -output-directory=auxiliary %.tex

Also if you want to see your PDF in the built-in viewer window, under Options > Configure TexStudio ...> Build put auxiliary for PDF File too.

  • 1
    The method you mentioned works fine under Windows texstudio+texlive.
    – ollydbg23
    Commented Mar 10, 2018 at 14:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .