3

I am new in the LaTex world. I just installed yesterday Texlive 2015 et texstudio (last version) on my windows 10 computer. Everything seems to be working properly except for the template "Article{french}" which refuses to compile any minimal working example. The problem may come from the french option or Texstudio parameters. The "collection lang-french" and "babel-french" are installed. I checked in the TexLive manager. From that point I read all I can to find a solution without any success.

Here is what I wrote:

    \documentclass[french]{article}
    \usepackage[T1]{fontenc}
    \usepackage[utf8]{inputenc}
    \usepackage{lmodern}
    \usepackage[a4paper]{geometry}
    \usepackage{babel}
    \begin{document}
     test
    \end{document}

Here is the log file:

 % les options suivantes (conseillées) par défaut :
\abbreviations
\disallowuchyph
\overfullhboxmark
\tthyphenation
\tabbingaccents
\automaticlettrine
% désactivez les options de frenchle pour '«' et '»' !
% test eFrench = {\befr}
\newcommand{\fbefr}{{\footnotesize E}F{\footnotesize RENCH}}
\DeclareRobustCommand{\befr}{\fbefr}

I cannot understand what all this means as I have no knowledge on computer or software at all.

Would someone understand or had any solution to make my texlive usable in french?

Thank you very much !


The posted file ran without error until the recent update replacing frenchle by e-french in texlive. The file now generates

(/usr/local/texlive/2015/texmf-dist/tex/generic/e-french/french.cfg
! Undefined control sequence.
l.2 \abbreviations

I'm using PdfLatex

  • You have shown a file with more tex source code, can you show instead the log file with the error? – David Carlisle Aug 20 '15 at 16:01
  • I added The error to the question, this appears to be related to a recent update in texlive in the last few days. – David Carlisle Aug 20 '15 at 16:26
4

babel-french has now been updated to avoid this problem, so the fix suggested below is no longer needed.


This is an unfortunate incompatibility in a the e-french files recently added.

The simplest (temporary) local fix is to add an empty file french.cfg to the folder containing your document. This file will then be read instead of the french.cfg in the e-french distribution.

  • 1
    Or alternatively, load babel with option noconfigs. – Javier Bezos Aug 20 '15 at 16:54
  • 3
    An update to babel-french, that should be available by tomorrow (2015-08-21), should fix the issue. See tug.org/svn/… – egreg Aug 20 '15 at 17:12
  • Adding an empty file french.cfg works for me. I wish I could understand why but I'm anyway happy it solves the problem. I also updated the babel-french package and it now works just fine. Many thanks for all your help ! – mailysmanu Aug 21 '15 at 12:38
5

The error is due to the inclusion of e-french (formerly frenchle) in TeX Live. An update to babel-french solves the issue.

Transcript when compiling the example with babel-french version 3.1g (TeX Live revision 37701)

> pdflatex manu
This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
(./manu.tex
LaTeX2e <2015/01/01> patch level 2
Babel <3.9m> and hyphenation patterns for 79 languages loaded.
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/fontenc.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/t1enc.def))
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/inputenc.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/utf8.def
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/t1enc.dfu)
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/ot1enc.dfu)
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/omsenc.dfu)))
(/usr/local/texlive/2015/texmf-dist/tex/latex/lm/lmodern.sty)
(/usr/local/texlive/2015/texmf-dist/tex/latex/geometry/geometry.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/local/texlive/2015/texmf-dist/tex/generic/oberdiek/ifpdf.sty)
(/usr/local/texlive/2015/texmf-dist/tex/generic/oberdiek/ifvtex.sty)
(/usr/local/texlive/2015/texmf-dist/tex/generic/ifxetex/ifxetex.sty))
(/usr/local/texlive/2015/texmf-dist/tex/generic/babel/babel.sty
(/usr/local/texlive/2015/texmf-dist/tex/generic/babel-french/frenchb.ldf
(/usr/local/texlive/2015/texmf-dist/tex/generic/babel/babel.def)
*************************************
* Local config file french.cfg used
*
(/usr/local/texlive/2015/texmf-dist/tex/generic/e-french/french.cfg
! Undefined control sequence.
l.2 \abbreviations

Transcript when compiling the example with babel-french version 3.1h (TeX Live revision 38160)

> pdflatex manu
This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
(./manu.tex
LaTeX2e <2015/01/01> patch level 2
Babel <3.9m> and hyphenation patterns for 79 languages loaded.
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/fontenc.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/t1enc.def))
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/inputenc.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/utf8.def
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/t1enc.dfu)
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/ot1enc.dfu)
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/omsenc.dfu)))
(/usr/local/texlive/2015/texmf-dist/tex/latex/lm/lmodern.sty)
(/usr/local/texlive/2015/texmf-dist/tex/latex/geometry/geometry.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/local/texlive/2015/texmf-dist/tex/generic/oberdiek/ifpdf.sty)
(/usr/local/texlive/2015/texmf-dist/tex/generic/oberdiek/ifvtex.sty)
(/usr/local/texlive/2015/texmf-dist/tex/generic/ifxetex/ifxetex.sty))
(/usr/local/texlive/2015/texmf-dist/tex/generic/babel/babel.sty
(/usr/local/texlive/2015/texmf-dist/tex/generic/babel-french/frenchb.ldf
(/usr/local/texlive/2015/texmf-dist/tex/generic/babel/babel.def)))
(/usr/local/texlive/2015/texmf-dist/tex/latex/carlisle/scalefnt.sty)
No file manu.aux.
(/usr/local/texlive/2015/texmf-dist/tex/latex/lm/t1lmr.fd)
*geometry* driver: auto-detecting
*geometry* detected driver: pdftex
[1{/usr/local/texlive/2015/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
(./manu.aux) ){/usr/local/texlive/2015/texmf-dist/fonts/enc/dvips/lm/lm-ec.enc}
</usr/local/texlive/2015/texmf-dist/fonts/type1/public/lm/lmr10.pfb>
Output written on manu.pdf (1 page, 23380 bytes).
Transcript written on manu.log.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.