0

This is an extension of this post.

In the code given below, if I comment out chapter 2, I can get the bibliography to show up correctly. If chapter 2 is uncommented, I do not get any bibliography:

\documentclass[paper=a4, pagesize=auto, BCOR=0.75cm, DIV=10, numbers=noenddot, captions=heading, captions=nooneline ,listof=totoc, bibliography=totoc, index=totoc, headings=normal, USenglish]{scrbook}

\usepackage{lipsum}

\usepackage[headsepline,footsepline,plainfootsepline]{scrpage2}
\pagestyle{scrheadings}

\setheadwidth[-7.5mm]{1.175\textwidth}
%
% headline color
\setheadsepline{.5pt}[\color{Navy}]
\setfootsepline{.5pt}[\color{Navy}]

\newcommand*{\ORIGchapterheadstartvskip}{}%

\let\ORIGchapterheadstartvskip=\chapterheadstartvskip

\renewcommand*{\chapterheadstartvskip}{%
  \ORIGchapterheadstartvskip
  {\color{Navy}%
    \setlength{\parskip}{0pt}%
    \noindent\rule[.3\baselineskip]{\linewidth}{1pt}\par
  }%
}
% see above
\newcommand*{\ORIGchapterheadendvskip}{}%
\let\ORIGchapterheadendvskip=\chapterheadendvskip
\renewcommand*{\chapterheadendvskip}{%
  {\color{Navy}%
    \setlength{\parskip}{0pt}%
    \noindent\rule[.3\baselineskip]{\linewidth}{1pt}\par
  }%
  \ORIGchapterheadendvskip
}

\usepackage{marvosym}

\usepackage{fix-cm, etex, thinsp, xspace, calc}
% --------------------------------------------------------------------
\usepackage[T1]{fontenc}        % EC fonts
\usepackage[utf8]{inputenc}     % coding UTF-8


\usepackage[showerrors, svgnames, table]{xcolor}

% --------------------------------------------------------------------
\usepackage{graphicx, rotating, ltablex, dcolumn, booktabs}
\usepackage{siunitx}

    \renewcommand{\floatpagefraction}{0.75}% Standard = 0.5
    \renewcommand{\textfraction}{0.15}% Standard = 0.2

    \renewcommand{\topfraction}{0.8}% Standard = 0.7
    \setcounter{topnumber}{3} % vorher: 2
    \setcounter{bottomnumber}{1} % vorher: 1
    \setcounter{totalnumber}{5} % vorher: 3

    \renewcommand{\dbltopfraction}{.8}% Standard = 0.7
    \renewcommand{\dblfloatpagefraction}{.6}% Standard = 0.5


    \tolerance 1414
    \hbadness 1414
    \emergencystretch 1.5em
    \hfuzz 0.3pt
    \widowpenalty = 2500
    \displaywidowpenalty = 2500
    \vfuzz \hfuzz
    \raggedbottom
\DeclareOption{tanz}{\raggedbottom}
\ProcessOptions\relax

  \deffootnote{2.25em}{1.75em}{\thefootnotemark.\enspace}

%========================================================================================
%   Bibliography
%========================================================================================

\usepackage[refsection=chapter,defernumbers=true,sorting=none,sortcites=true,autopunct=true,babel=hyphen,hyperref=true,abbreviate=false,backref=true,backend=biber]{biblatex}   \addbibresource{chap1.bib}% BibTeX
 \defbibheading{bibempty}{}
 \newcommand*{\refname}{Bibliography}

\usepackage{expl3,xparse}
\ExplSyntaxOn% syntax of expl3 on

\cs_new_eq:Nc \emph_old:n { emph~ } % Copying the old definition of `\emph`
\cs_new_eq:NN \emph_braces:n \textup % Braces should be typeset upright.
\cs_new:Npn \emph_new:n #1 {
    \tl_set:Nn \l_emph_tl {#1}
    \tl_replace_all:Nnn \l_emph_tl {(}{\emph_braces:n{(}}
    \tl_replace_all:Nnn \l_emph_tl {)}{\emph_braces:n{)}}
    \tl_replace_all:Nnn \l_emph_tl {[}{\emph_braces:n{[}}
    \tl_replace_all:Nnn \l_emph_tl {]}{\emph_braces:n{]}}
    \exp_args:NV \emph_old:n \l_emph_tl
}
\RenewDocumentCommand {\emph} {sm} {
    \IfBooleanTF {#1} {\emph_old:n {#2}}
    {\emph_new:n {#2}}
}
          %
\AtEveryCitekey{\RenewDocumentCommand{\emph}{m}{%
    \emph_old:n {#1}}
}
\AtBeginBibliography{\RenewDocumentCommand{\emph}{m}{%
    \emph_old:n {#1}}
}
\ExplSyntaxOff% syntax of expl3 on
%
% --------------------------------------------------------------------

\usepackage[iso]{isodate}

% --------------------------------------------------------------------
% line breaks in URLs at "-"
\PassOptionsToPackage{hyphens}{url}
% --------------------------------------------------------------------
% PDF settings
\ifpdfoutput{% needs a KOMA-Script class!!!

\usepackage[final, kerning, babel, protrusion=true, expansion=true, tracking=true]{microtype}
   \DeclareMicrotypeSet*[tracking]{my}{ font = */*/*/sc/* }%
      \SetTracking{ encoding = *, shape = sc }{ 45 }

\usepackage[pdftex, plainpages=false, colorlinks, linkcolor={Navy}, citecolor={Navy}, linktocpage={true}, breaklinks, pdfcreator={pdflatex}, pdfstartview=FitH, bookmarksopen=true]{hyperref}
%
\usepackage{bookmark}% bookmark cleanup
}%
%% -----------------------------------
%% non-PDF branch
{%
   \usepackage[xetex,linktocpage={true}, breaklinks]{hyperref}
%
% optimized margin alignment with microtype:
   \usepackage[final, DVIoutput, kerning, babel, protrusion=true]{microtype}
}
%
\usepackage[figure]{hypcap} % links to the upper edge of floating environments
%
%% ============================================================================
% extended handling of figures
\usepackage[caption=false]{subfig}
%
%% ============================================================================
% intelligent cross references
\usepackage{cleveref}
%% ============================================================================
% Fonts
\usepackage{textcomp} % Text Companion fonts which provide many text symbols in the TS1 encoding.
%
%% -- Palatino with Bera fonts
    \linespread{1.05}\selectfont      % line spread for Palatino
    \usepackage[scaled=.88]{beramono} % Bera-Monospace
    \usepackage[scaled=.86]{berasans} % Bera Sans-Serif
    \usepackage[sc,osf]{mathpazo}     % Palatino with small caps and minuscel numbers

\usepackage{amsmath}

\usepackage{fixmath}

   \typearea[current]{last}    % with DIV=[number]

\usepackage{textcomp} % required for \texteuro
\usepackage{eurosym}  % required for \euro

\usepackage{lscape} %landscape pages support

\usepackage{imakeidx}
\makeindex[options=-s StyleInd.ist]

\begin{document}

%% ============================================================================
\KOMAoptions{cleardoublepage=plain}
\addtokomafont{caption}{\centering}% all caption lines as multilines
%% ============================================================================

\frontmatter

\subject{\ }
\title{WinEdt}
\subtitle{Quick Guide}
\author{\textsc{Aleksander Simonič}\\ \small{\copyright~1993--2015}}
\date{}
%

\maketitle

\tableofcontents

\listoffigures

\mainmatter

\chapter{First Chapter}
This chapter give you an idea of how the reference is not showing up \cite{egan}.
\section{Test 1}
\lipsum
%\chapter{Second Chapter}
%\lipsum


\backmatter

%\printbibliography
\section*{Bibliography}
\addcontentsline{toc}{section}{Bibliography}

\subsection*{Books}
\printbibliography[heading=bibempty,type=book,prefixnumbers={B}]

\subsection*{Articles}
\printbibliography[heading=bibempty,type=article,prefixnumbers={A}]

\subsection*{Online}
\printbibliography[heading=bibempty,type=online,prefixnumbers={O}]

\cleardoublepage
\setlength{\columnsep}{0.75cm}
\addcontentsline{toc}{chapter}{\textcolor{ocre}{Index}}
\printindex

\end{document}

Can you tell me how I can get the bibliography to work with more than one chapters?

1
  • Please reduce your code to the minimum necessary to reproduce the problem. As was pointed out to you before, you almost certainly are not using everything in the preamble and you ought not be using half of the rest. Cleaning up your preamble will, in itself, help to avoid weird problems and will make diagnosing and solving problems easier. Really. Time spent cleaning up your code will save you time in the end.
    – cfr
    Aug 21, 2015 at 2:43

1 Answer 1

1

You are using refsection=chapter. Within a chapter, therefore, you get the references for only that chapter. The bibliography you print here is for chapter 2. But there are no references for chapter 2 because nothing is cited. Hence, there is no bibliography to print. Add the commands you want to the first chapter, rather than the second.

\usepackage[refsection=chapter,defernumbers=true,sorting=none,sortcites=true,autopunct=true,babel=hyphen,hyperref=true,abbreviate=false,backref=true,backend=biber]{biblatex}

If you don't want to use per-chapter reference sections, don't tell Biblatex to do that:

\usepackage[sorting=none,sortcites=true,autopunct=true,babel=hyphen,hyperref=true,abbreviate=false,backref=true,backend=biber]{biblatex}

Are you sure that you want sorting=none and babel=hyphen?

7
  • How to make this work for the entire document? Meaning, I would just like to print one bibliography at the end of the document for all the chapters.
    – Joe
    Aug 21, 2015 at 2:53
  • 1
    @Joe But you have told Biblatex that you want separate references for each chapter. That is what refsection=chaptermeans. If you don't want that, delete that option and the defernumbers one.
    – cfr
    Aug 21, 2015 at 2:55
  • 1
    @Joe see edit...
    – cfr
    Aug 21, 2015 at 2:58
  • I use sorting=none because I want to cite as I go along the main document. babel = hypen breaks up the words for me correctly. Is it not normal practice to have hyphens for your bibliography?
    – Joe
    Aug 21, 2015 at 3:06
  • 1
    @Joe Fair enough. I can't find babel in the documentation. I get hyphens without it, but my entries are always the main document language anyway. Well, almost always. Otherwise, I'd probably use a language option rather than just a hyphenation pattern. (And I'd use the corresponding field in the .bib entry rather than hyphenation - some of my entries do specify a language, in fact.)
    – cfr
    Aug 21, 2015 at 13:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .