3

I'm using the \documentclass[journal]{IEEEtran} and the table title appears in lower case letters as: (Table I.) But, it is supossed that whitin this class the table title should go in uppercase, I'm just wondering what my problem is about.

here is a basic example:

\documentclass[journal]{IEEEtran}
\usepackage{cite}
\usepackage[cmex10]{amsmath}
\usepackage{url}
\usepackage[english]{babel}
\usepackage[utf8x]{inputenc}
\usepackage{graphicx}

\begin{document}

\begin{table}[!h]
\renewcommand{\arraystretch}{1.3}
\caption{Comparison}
\label{tab:1}
\centering
\begin{tabular}{*7c}
\hline
{} & \begin{tabular}[c]{@{}c@{}}Medium \\Reflectivity \% \end{tabular}& \multicolumn{3}{c}{\begin{tabular}[c]{@{}c@{}}Sub-bands' \\FWHM [pm]\end{tabular}} & \multicolumn{2}{c}{\begin{tabular}[c]{@{}c@{}}Sub-bands' \\Distance [pm]\end{tabular}}\\
\hline
Design S1 & 30 & 40 & 40 & 40 & 100 & 300 \\
S1 & 31.5 & 40.8 & 42.8 & 37.76 & 104 & 294 \\
Design S2 & 30 & 40 & 40 & 40 & 200 & 500 \\
S2 & 30.7 & 40.3 & 39.8 & 39.3 & 194 & 490 \\
\hline
\end{tabular}
\end{table}

\end{document}
3
  • Welcome to TeX.SX! Please show us a minimal working example so that we do not have to guess. Thanks.
    – LaRiFaRi
    Aug 24, 2015 at 10:12
  • I get uppercase "TABLE" when taking out babel, so I guess that's the culprit.
    – campa
    Aug 24, 2015 at 10:28
  • Unrelated: don't use the cmex10 option to amsmath; it is only for compatibility with very old TeX distributions. And “very old” means about 20 years.
    – egreg
    Aug 24, 2015 at 10:42

1 Answer 1

2

While the class IEEEtran defines

\def\tablename{TABLE}

the package babel (rather, the language-specific file english.ldf) re-defines it back to

\def\tablename{Table}

Adding (thanks to egreg for the suggestion)

\addto\captionsenglish{\renewcommand*{\tablename}{TABLE}}

in the preamble after \usepackage{babel} should fix it.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .