0

I am using the Overleaf web site to put together an article, and this uses this code. I am getting the error I posted below and have not idea what to, any help would be great, not sure why even need to mess with code to do this! :/

Thanks!

Undefined control sequence.
\u-default-956 #1->\textmu 

l.31 ...Pressure mode with an aperture of 30.00 μ
                                                  m, and a voltage of 10 kV....
  • Welcome to TeX.SX! Without knowing what you input to overleaf we can't tell for sure what is going wrong... Possibly you can fix your error by adding \usepackage{textcomp} in the preamble as \textmu seems to be undefined. – Ruben Aug 24 '15 at 20:15
  • To be honest I did not really "enter" anything. I copy and pasted in text from word where the template told me too. – Jason Testin Aug 24 '15 at 20:20
  • this is what I get when I click on the source button "\subsection{Scanning Electron Microscope} The Scanning Electron Microscope (SEM) used was the South Dakota School of Mines and Technologies’ Zeiss Supra40 Variable-Pressure Field-Emission Scanning Electron Microscope. The SEM was set to High Pressure mode with an aperture of 30.00 μm, and a voltage of 10 kV. All images were taken using the Secondary Electron Emission detector." – Jason Testin Aug 24 '15 at 20:20
  • Here is what you do: You go to "source" mode (if you're not alredy there), cancel out everything that does not contribute to the error in order to have a minimal working example (MWE) and edit it into your post here. Doing so we can see exactly where the misbehaviour occurs because overleaf in the end uses plain LaTeX. Hence, we have to see what is going wrong on the LaTeX (source) side. – Ruben Aug 24 '15 at 20:29
  • When you are in "source" mode, try adding the package I proposed somewhere in between \documentclass... and \begin{document} (the preamble). – Ruben Aug 24 '15 at 20:30
2

The error message tells you are using Unicode input encoding via package ucs and option utf8x of package inputenc. If you do not need ucs special features, then \usepackage[utf8]{inputenc} is the more common way.

The μ from the input is mapped to \textmu, which is not provided yet. Package textcomp provides it, for example, as suggested in Ruben's comment.

A more powerful way setting units is provided by package siunitx. It also takes care of the space between number and unit and prevents a line break between them.

\usepackage{siunitx}
\SI{30.00}{\micro\meter} ... \SI{10}{\kilo\volt}

Full example and my suggestion:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{siunitx}

\begin{document}
  Pressure mode with an aperture of \SI{30.00}{\micro\meter},
  and a voltage of \SI{10}{\kilo\volt} \dots
\end{document}

Result

Or keeping units manually, keeping ucs and adding textcomp, the example would be:

\documentclass{article}
\usepackage{ucs}
\usepackage[utf8x]{inputenc}
\usepackage{textcomp}

\begin{document}
  Pressure mode with an aperture of 30.00\,μm,
  and a voltage of 10\,kV \dots
\end{document}

Result

The \, sets a small non-breakable space, often set between the numbers and their units. The tilde ~ sets a normal non-breakable space.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.