9

Here's the MWE:

\documentclass{beamer}

\usepackage{siunitx}
\usepackage{newtxtext,newtxmath}
\usepackage{bm}

\begin{document}

\end{document}

Everything works with documentclass report. Currently, with beamer, I'm getting

! LaTeX Error: Too many symbol fonts declared. ...
! LaTeX Error: Too many math alphabets used in version normal. ...
! LaTeX Error: Too many math alphabets used in version normal. ...

By removing siunitx, I can eliminate the math errors. And by removing any of the other two, all errors disappear. But I need all to use all of these packages (a lot of my material from the corresponding report assumes these). How do I make this work?

12

Option professionalfont helps to reduce the font declarations by beamer (older versions):

\documentclass[professionalfont]{beamer}

\usepackage{siunitx}
\usepackage{newtxtext,newtxmath}
\usepackage{bm}

\begin{document}
\end{document}

Newer beamer versions want a font theme instead of the option:

\documentclass{beamer}
\usefonttheme{professionalfonts}

\usepackage{siunitx}
\usepackage{newtxtext,newtxmath}
\usepackage{bm}

\begin{document}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.