1

I tried to add on the LyX (Windows 10) Layouts folder some .layouts, and after I run "Tools -> Reconfigure" and restarting LyX it doesn't neither the default classes.

How can I solve this problem? I already tried to disable "Install Missing Packages on-the-fly" on MikTeX 2.9 but still isn't able to load the classes.

Missing default Document Classess

1

I solved this removing the new file I add in the LyX Layouts folder. So it looks like a bug. So I guess I must load "local layouts" every time.

  • Did you put the new file in the system LyX layouts folder or the user dir layouts folder? The user dir layouts folder is the correct place for user layouts. Also, what is the output of reconfigure? You should be able to see it in view > messages pane. – scottkosty Aug 27 '15 at 12:27
  • Hi, yes but even if I put the layout file in the user folder (App Data...) I still get the same error. To solve this problem: 1 - I removed the .layout file I am trying to use from the Layouts folders (both user and for all users). 2 - I run the Reconfigure and after restarting LyX, all the previous default document classes were add. 3 - To use the layout file that I want, on Lyx, I put the .layout file in the same folder I have my LyX file. 4 - Using the option "Local Layouts", I selected the .layout file, and now when I close and open the Lyx, I don't get any error. Thanks for your help. – Renan Alves de Oliveira Aug 27 '15 at 13:01
  • I see. I hope that you can post this information as well as the output from the reconfigure, on a bug report at lyx.org/trac . The only way we can fix the bug is if we know about it and I've never heard of this one before. – scottkosty Aug 27 '15 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.