14

I am trying to modify a CV I created on my old notebook. I have a fresh install of MiKTeX and TeXstudio on my new system, but my CV won't compile. I am using PDFLaTeX to compile. Originally, I created my CV from the built in moderncv template. Strangely enough it compiles if I choose the classic and not the casual option but the font doesn't really seem different.

Trying to make PK font FontAwesome--fontawesometwo at 600 DPI...

Running miktex-makemf.exe...

miktex-makemf: The FontAwesome--fontawesometwo source file could not be found. Running ttf2pk.exe...

miktex-makepk

: PK font FontAwesome--fontawesometwo could not be created.

What I have tried so far:

  • Copying the fonts folder from my old system's MiKTeX installation
  • Running initexmf --mkmaps and initexmf --update-fndb
  • Reinstalling the font with the package manager
  • I tried the solution provided here, didn't work.

I am using Windows 10, MiKTeX 2.9, and TeXstudio 2.9.4.

\documentclass[11pt,a4paper,sans,english]{moderncv}        % possible options include font size ('10pt', '11pt' and '12pt'), paper size ('a4paper', 'letterpaper', 'a5paper', 'legalpaper', 'executivepaper' and 'landscape') and font family ('sans' and 'roman')
\moderncvstyle{casual}                             % style options are 'casual' (default), 'classic', 'oldstyle' and 'banking'
\moderncvcolor{blue}                               % color options 'blue' (default), 'orange', 
\usepackage[utf8]{inputenc}                       % if you are not using xelatex ou lualatex, replace by the encoding you are using
\usepackage[scale=0.75,a4paper]{geometry}
\usepackage{babel}
%----------------------------------------------------------------------------------
%            personal data
%----------------------------------------------------------------------------------
\firstname{first name}
\familyname{family name}
\title{Resumé title}                               % optional, remove/comment the line if not wanted
\address{street and number}{postcode city}{country}         % optional, remove/comment the line if not wanted; the "country" arguments can be omitted or provided empty
\mobile{mobile number}                          % optional, remove/comment the line if not wanted
\phone{phone number}                           % optional, remove/comment the line if not wanted
\begin{document}
%-----       resume       ---------------------------------------------------------
\makecvtitle
\section{Education}
\cventry{year--year}{Degree}{Institution}{City}{Grade}{Description}  % arguments 3 to 6 can be left empty
\cventry{year--year}{Degree}{Institution}{City}{Grade}{Description}
\clearpage
\end{document}
  • 1
    For others to help, is it a good idea to provide a small but full document that others can copy to their own system and test. For example here we cannot see how you have asked for FontAwesome. – daleif Aug 28 '15 at 9:53
  • I am working on it, thanks for the suggestion. – spinakker Aug 28 '15 at 10:03
  • Did you try running \updmap in an administrator console? – Bernard Aug 28 '15 at 10:18
  • 5
    Compile \documentclass{article} \pdfmapfile{=fontawesome.map} \usepackage{fontawesome} \begin{document} \faFlag \end{document} and if it works show the log-file. – Ulrike Fischer Aug 28 '15 at 13:36
  • 2
    Looks fine, everything is there. Now run on a command line (in your user account) updmap. Comment \pdfmapfile{=fontawesome.map} in the example and try again. Does it work? – Ulrike Fischer Aug 28 '15 at 14:16
9

The newest version of the modernCV template somehow doesn't mesh well with the rest of my system. Downgrading to an older version of the template solved the problem.

Using TeX Live 15 should also work.


Actual solution: Add the line Map fontawesome.map to the updmap.cfg file. Many thanks to @UlrikeFischer for walking me trough it.

  • Thanks @spinakker, where can I find this updmap.cfg file? – Brian Mayer Jul 20 '16 at 0:50
  • 1
    In a Command Prompt window, run initexmf --edit-config-file updmap – Katsu Oct 17 '16 at 16:18
  • 2
    Wow, this actually fixed it, I can't believe it. Thank you. I opened a command prompt window, typed initexmf --edit-config-file updmap , then the file updmap.cfg opened automatically in notepad and I added the line Map fontawesome.map, then back at the command prompt I typed initexmf --mkmaps, and then I was able to compile my CV successfully (using TexStudio). (I followed the instructions for updating updmap.cfg that I found here.) – littleO Oct 1 '18 at 4:37
1

I had this same problem on my system...the FontAwesome seems to be called only by the "casual" style file, and not the "classic", which is why one can get the "classic" to compile and not the "casual" style. I would just recommend that you use the classic style, or whichever compiles for you!

0

I had the same problem, I solved it as suggested here :

  1. open the miktex package manager (admin) and uninstall fontawesome

  2. install fontawesome with non admin package manager

0

If you want to use pdflatex, here is one solution, which edits the moderncv style files. (Not sure how this will persist on update of your latex distribution)

The moderncv.cls config files define three styles of icons:

  1. awesome (moderncviconsawesome.sty)
  2. marvosym (moderncviconsmarvosym.sty)
  3. letters (moderncviconsletters.sty)

The awesome style is loaded in most options for \moderncvstyle (except classic, which loads marvosym and oldstyle, which loads letters). The awesome style does not work with pdflatex, but I honestly can't tell the difference between this and marvosym. So, my solution is to:

Replace \moderncvicons{awesome} with \moderncvicons{marvosym} in all style files:

moderncvstyle*.sty, where * = {banking,casual,fancy} (and oldstyle too if you prefer).

Not sure why awesome is the default, given the compatibility issues, but hopefully this helps.

  • I wouldn't worry about a latex distribution update, because the missing Map file entry would probably be fixed by any bigger update. (Also, I wouldn't expect any moderncv updates anymore) Anyway, is there a reason why you suggest changing the style file instead of changing the icon style after the style is loaded? (I mean adding \moderncvicons{...} after \modercvstyle{...}) Then you would not have to worry about updates reverting your changes and your document will behave consistently on other systems. – Marcel Krüger Apr 24 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.