0

I am using the font Open Sans Condensed Light for my CV. In some parts of my CV I need to bold some text, so I use \textbf{} command. However, it does not work.

How can I solve my problem?

Thanks in advance!

Here is a MWE:

\documentclass[fontsize=11pt]{tccv}

\usepackage{fontspec,xgreek}
\defaultfontfeatures{Mapping=tex-text}
\setromanfont[Mapping=tex-text]{Open Sans Condensed Light} 

\usepackage{polyglossia}
\setdefaultlanguage{english}
\setotherlanguage[variant=modern]{greek}


\begin{document}

\section{Εκπαίδευση}

\begin{yearlist}

\item[Environmental Economics \& Management]{2012 -- 2015}
     {\textbf{MSc in Business \& Economics}}
     {University}


\end{yearlist}
\end{document}
  • What error message do you get printed on the terminal? – Au101 Aug 28 '15 at 15:14
  • I don't get an error. The problem is that the text remains "unbold". I don't know if the problem is the font I use... – Yorgos Aug 28 '15 at 15:18
  • I am not sure if that light font has bold version. – Sigur Aug 28 '15 at 15:30
  • 1
    having specified a light font to be the normal weight it isn't going to get the variants automatically, you'll need to declare that (presumably) you want the normal weight font to be \bfseries – David Carlisle Aug 28 '15 at 15:32
  • @Sigur The .zip file with the font included Open Sans Condensed Light , Open Sans Condensed Light italic, Open Sans Condensed bold – Yorgos Aug 28 '15 at 15:33
4

Open Sans Condensed comes in Light, Light Italic, and Bold, with no Bold Italic.

You can use it like this:

\documentclass[20pt]{beamer}
\usepackage{fontspec}
\usefonttheme{professionalfonts}
\setsansfont{Open Sans Condensed Light}[
  Numbers=OldStyle,
  ItalicFont={* Italic},
  BoldFont={Open Sans Condensed Bold}]
\begin{document}
\begin{frame}
  \frametitle{Open Sans Condensed}

  \textbf{Boldly} \textit{emphasizing} nonsense.

  \textbf{123} \textit{456} 7890
\end{frame}
\end{document}

output of sample code

If you have an old version of fontspec, you should put the options between \setsansfont and {Open Sans Condensed Light}; you can do that anyway if you prefer.

For reasons unknown, TeX Live includes the Condensed Light fonts but not the Condensed Bold. You may wish to write to the package maintainer about this, but that would benefit people using pdftex more than xetex or luatex.

At any rate, I wouldn’t use the bold and the light together under ordinary circumstances: usually one pairs bold with regular, and semi-bold with light.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.