5

I have a bibliography which refuses to settle. It keeps switching between two states:

end first page state a

next page:

begin second page state a

and

end first page state b

next page:

enter image description here

It seems that biblatex, or biblatex-chicago, when replacing the author's name with a horizontal line, doesn't like such an entry to be the first on a new page and thus reverts to the name, which then makes the entry grow to four lines, latex then redistributing these lines differently over the two pages, the entry ending up on the previous page, so that its name needs to be replaced by the horizontal line, shortening it to three lines, which then leads to a reversion back to the first state.

Here a minimised latex file which with this bib file reproduces the problem:

\documentclass[11pt]{memoir} \usepackage{pgffor} %%% Font Setup
\usepackage{fontspec,xltxtra,xunicode}
\setromanfont[Mapping=tex-text,Numbers=OldStyle,SmallCapsFont={* Caps}]{Latin Modern Roman}

%%%Page setup
\quarkmarks
\setpagecc{24.1cm}{16.4cm}{*}
\settypeblocksize{*}{11.8cm}{*}
\setlrmargins{2.1cm}{*}{*}
\setulmarginsandblock{2.1cm}{2.5cm}{*}
\checkandfixthelayout

%%%Bibliography Setup
\usepackage[authordate,backend=biber]{biblatex-chicago}
\setlength\bibitemsep{0pt} % no empty line between bib entries
\renewcommand*{\bibfont}{\small}


\addbibresource{ch01sec.bib}
\begin{document}
\foreach \n in {0,...,52}{X\\}
\nocite{*}
\printbibliography[heading=subbibliography]
\end{document}

I have already reported this to the maintainer of biblatex-chicago, who then suggested to ask here, as he thinks it's a general biblatex-issue.

  • 1
    This is something I have come across once or twice myself. I think it is a bit drastic to call this a bug. It is an unfortunate consequence of what biblatex does. One could probably make the problem go away in an ad-hoc manner by changing some penalties (I'm not sure which ones that would be though). – moewe Sep 1 '15 at 9:03
6

If you don't care about dashes at the start of the pages you can disable the pagetracker before the bibliography:

\pagetrackerfalse
\printbibliography[heading=subbibliography]

If you care then you probably will have to adjust the bibliography manually when all bib-entries are there. You can then e.g. identify the first problematic entry and add a hard pagebreak:

\AtEveryBibitem{\iffieldequalstr{entrykey}{Sanderson2009}{\pagebreak}{}}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.