1

I'm currently writing a report in LaTeX and yesterday everything worked fine. Today however, biber isn't working properly (aka at all). I always get the following error:

Use of uninitialized value $alias in hash element at C:\Users\XXX\AppData\Local\Temp\par-4f6c65\cache-...\inc\lib/Biber/Section.pm line 469.

Use of uninitialized value $citekey in hash element at C:\yada-yada\inc\lib/Biber/Entries.pm line 57.

Can't call method "datafields" on an undefined value at C:\yada-yada\inc\lib/Biber/Entry.pm line 537.

Until now I deleted the temp-Folder but that changes nothing. I reinstalled Biber as well as biblatex, but nothing changed. I removed MikTex and installed TeXLive 2015, but the error is still not gone.

My library.bib looks like (I mean it's bigger, but the error occurs also with only one entry):

% This file was created with JabRef 2.10.
% Encoding: UTF8
@Article{Asahara2015,
  Title                    = {Synthesis of diazabicyclo compounds possessing an $\alpha$-nitrolactam framework},
  Author                   = {Asahara, Haruyasu and Takeda, Shota and Saigo, Kazuhiko and Nishiwaki, Nagatoshi},
  Year                     = {2015},
  Doi                      = {10.1016/j.tetlet.2015.03.100},
  Note                     = {Chalcone synthesis in methanol and water},
  Number                   = {19},
  Pages                    = {2504-2507},
  Url                      = {http://www.sciencedirect.com/science/article/pii/S0040403915005705
http://ac.els-cdn.com/S0040403915005705/1-s2.0-S0040403915005705-main.pdf?_tid=63db364c-4f12-11e5-b336-00000aacb360&acdnat=1440937790_8b4e5199eeccaac75bf2e4028421335f},
  Volume                   = {56},

  Abstract                 = {Diazabicyclo compounds possessing an $\alpha$-nitrolactam framework were directly synthesized upon treatment of $\alpha$-nitro-$\delta$-keto esters with diamines. This reaction proceeds via pseudo-intramolecular process. In this process, the formation of ammonium nitronate is a key step, by which the amino group and the ketone carbonyl group are in close proximity to cause the imine formation efficiently. The following tandem bicyclization constructs 1,7-diaza-3-nitro-2-oxobicyclic systems having two aryl groups at the 4- and 6-positions.},
  Journal                  = {Tetrahedron Letters},
  Keywords                 = {Bicyclic compound
Michael addition
Nitroacetate
Pseudo-intramolecular process},
  Type                     = {Journal Article}
}

Hope someone has a solution :)

closed as unclear what you're asking by moewe, Jesse, user11232, Svend Tveskæg, Andrew Swann Sep 26 '15 at 8:43

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you tried putting curly brackets around the maths? Also, have you deleted generated files from the working directory? (.bcf, .bbl, .aux etc.) In general, it helps to have a full example matching an actual error so that the line numbers match, although I think in this case they maybe lines in the perl library so it doesn't matter. – cfr Sep 1 '15 at 11:56
  • Adding a minimal document, it works fine for me. But I'm not using Windows so Perl is going to be pretty different. – cfr Sep 1 '15 at 12:02
  • It happens from time to time that biber cache directorygets corrupted. Delete the directory: C:\Users\XXX\AppData\Local\Temp\par-4f6c65 and try start afresh. – Bernard Sep 1 '15 at 12:02
  • I tried curly brackets, removing the generated files as well as the temporary directory and compiled again. Error is still there. – O2_AC Sep 1 '15 at 12:02
  • Test a small example which doesn't use your bib but uses biblatex-examples.bib and e.g. cites "shore". Does it break too? – Ulrike Fischer Sep 1 '15 at 12:03
0

I solved the problem, I don't know why but for some reason this small snippet in my main document caused the error:

\defbibentryset{ref}{ref1,ref2}
  • You could open a entry at the issue tracker of biber: github.com/plk/biber/issues. – Ulrike Fischer Sep 1 '15 at 12:27
  • 1
    But if you do so, please make sure you have a full MWE at hand so the issue can be reproduced by the developers. – moewe Sep 1 '15 at 12:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.