2

I can manually run bibtex, but how do I setup Tex Studio's PDF Chain to include bibtex?
Tex Studio on my Windows machine works fine.

Cheers,
Nap

  • 1
    Open OptionsConfigure TeXstudio In the tab that opens change the field for build & View (under Meta Commands) as: txs:///compile | txs:///bibliography | txs:///compile| txs:///compile | txs:///view (By default it will read: txs:///compile | txs:///view. Give OK and exit. Now use the double arrow (Build & View) to compile. – user11232 Sep 2 '15 at 6:19
  • Or use arara. Using Latexmk` is also one possibility. – user11232 Sep 2 '15 at 6:20
  • @Harish: Thanks. Your first comment works fine. It refers to the double arrow. Which option modifies the behaviour of the single arrow? (Also, if you post it as an answer, I will accept it.) – gone Sep 2 '15 at 6:52
  • Please mention the need to select Advanced Options – gone Sep 2 '15 at 7:22
4

In TeXstudio, open Options and then Configure TeXstudio. This opens:

enter image description here

In this window, check the Show Advanced Options at the lower left corner. Now, in Build tab, the first field (under Meta Commands) Build & View has this argument:

txs:///compile | txs:///view 

Change it to

txs:///compile | txs:///bibliography | txs:///compile| txs:///compile | txs:///view

This is for running pdflatex, bibtex, pdflatex, pdflatex and then View.

Press OK and exit.

Now pressing double arrow (as shown below) in TeXstudio should do the job.

enter image description here

For single arrow (i.e., Compile) you should change the second one as shown in this picture:

enter image description here

  • One can also see the User commands for arara and makeglossaries in the first picture. – user11232 Sep 2 '15 at 7:08
  • Could you explain how the "Repeating" button works (in your screenshot, the Default Compiler line, the repeating button is on. I think it should help in simplifying the build chain we define, i.e. instead of 5 items on the chain, we only need 3? – Jim Raynor Feb 22 '16 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.