2

I am making a critical edition that has some Sanskrit text in which I would like the numbers in the critical apparatus referring to the line numbers in the text to be bold. The problem is that the Sanskrit font I am using, Nakula, has no boldfaced form. How can I, for example, use the default LaTeX Roman script for the line numbers in the critical apparatus? How do I reset the font that is used for the line numbers in the critical apparatus? You can get the Devanagari font, Nakula, here.


\documentclass{article}

\usepackage{reledmac}

\usepackage{fontspec}

\usepackage{polyglossia}
    \setmainlanguage{english}
    \setotherlanguage{sanskrit}
    \newfontfamily\devanagarifont{Nakula}


\begin{document}

\Xnotenumfont{\bfseries}

\noindent This is an edition of the \emph{Samādhirājasūtra}.

\vspace{30pt}

\beginnumbering
    \autopar

\devanagarifont
\begin{sanskrit}
\noindent तत्र \edtext{खलु}{\Afootnote{A; एव B}} भगवान् पुनरपि चन्द्रप्रभं बोधिसत्वमामन्त्रायते स्म॥
 तस्मात् तर्हि कुमार बोधिसत्वेन महासत्वेन सर्वधर्मानां महाभिज्ञापरिकर्म परिशोधयितुकेमनायं समाधिः श्रोतव्यः॥

\end{sanskrit}

\endnumbering

\end{document}

enter image description here

1

Use

\Xnotenumfont{\normalfont\bfseries}
0

Use FakeBold:

\documentclass{article}

\usepackage{reledmac}

\usepackage{fontspec}

\usepackage{polyglossia}
\setmainlanguage{english}
\setotherlanguage{sanskrit}
\newfontfamily\devanagarifont{Nakula}[
  BoldFont=Nakula,
  BoldFeatures={FakeBold=4},
]


\begin{document}

\Xnotenumfont{\bfseries}

\noindent This an edition of the \emph{Samādhirājasūtra}.

\vspace{30pt}

\beginnumbering
    \autopar

\devanagarifont
\begin{sanskrit}
\noindent तत्र \edtext{खलु}{\Afootnote{A; एव B}} भगवान् पुनरपि चन्द्रप्रभं बोधिसत्वमामन्त्रायते स्म॥
 तस्मात् तर्हि कुमार बोधिसत्वेन महासत्वेन सर्वधर्मानां महाभिज्ञापरिकर्म परिशोधयितुकेमनायं समाधिः श्रोतव्यः॥

\end{sanskrit}

\endnumbering

\end{document}

enter image description here

  • Thanks, I didn't know about fakebold. The best solution would be to use the standard LaTeX font, though, as the fakebold bold font is a little too bold. There is an option in reledmac to change the font of the line numbers, but I'm not sure how to use it: "Line numbers for the main text are usually printed in a smaller font in the margin. The \numlabfont macro is provided as a standard name for that font: it is initially defined as \newcommand{\numlabfont}{\normalfont\scriptsize}" – Paul Sep 2 '15 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.