6

Since the update on August 29, the updater finishes with a message log4cxx: no appender could be found for logger. MikTeX remains functional, but the caching of fonts that usually happens at the end of the update process seems to be skipped.

This happens on four different machines, running both Windows 10 and 7. I installed months ago, from the Miktex web site. At the end of the update process, the following appears:

Copying C:\Users\mrenardy\AppData\Local\MiKTeX\2.9\pdftex\config\pdftex_dl14.map 
to C:\Users\mrenardy\AppData\Local\MiKTeX\2.9\pdftex\config\pdftex.map... 
log4cxx: No appender could be found for logger (mkfntmap). 
log4cxx: Please initialize the log4cxx system properly. 
Creating language.dat, language.dat.lua and language.def... 

I have Comodo Firewall on all machines.

One has Comodo AV, the others have Symantec.

I have not filed a bug report, but have emailed this to Christian Schenk.

I know from surfing the web that others have seen the same message. Miktex so far has functioned normally for me, notwithstanding the error message. I note that the hundreds of lines that say fonts are being cached or that the existing cache is valid no longer appear during the update process. Being just a dumb user, I cannot tell whether the fonts are not being cached or just no message created.

9
  • Start the package manager (admin), synchronize (menu repositories) and check if all miktex-packages are installed (specifically the miktex-log4cxx package). – Ulrike Fischer Sep 2 '15 at 15:39
  • @UlrikeFischer I think there is some problem with new update. I can confirm the error now after an update and none of the engines work!. – user11232 Sep 6 '15 at 13:33
  • @HarishKumar: My miktex is up-to-date and works fine. Also the question here didn't claim that "none of the engines" worked. Did you synchronized the package manager (admin) and installed all new miktex-packages? – Ulrike Fischer Sep 6 '15 at 13:40
  • @UlrikeFischer Yes I did. Now I tried to uninstall the log4cxx binaries and tried to re-install. But got error. I am trying hard to roll back the update. But ran out of ideas at present :( I am on windows 10 BTW. – user11232 Sep 6 '15 at 13:55
  • 2
    I can confirm that there are messages by log4cxx about initializing it properly. (I suspect this has to do with the new/planned log file feature announced on the MikTeX page.) But I have yet to experience actual problems related to this. – moewe Sep 12 '15 at 9:33
2

I got the same message on Win7 Enterprise-MikTeX2.9. however everything seems OK and I hope it is something that has been left over from developer debugging. This site https://dilawarnotes.wordpress.com/2013/02/01/log4cxx-no-appender-could-be-found-for-logger-somelogger/ and others gives me that impression, but I am a non-expert user. I tried their suggestion but, of course, just get "nothing needs updating".

I had to execute the standard in LyX then everything went from crashed to normal :-) (The reconfigure is specific for LyX to estabilish the correct backend LaTeX settings).

1

If someone should stumble upon this and the suggested hints do not work, this may help you:

On my work machine, I can only install software with a special elevated account, while I'm usually logged in with my base-level user account. The effect was that with MikTeX, when I installed with elevated privileges, I also got the

log4cxx: No appender could be found for logger (xxx). 
log4cxx: Please initialize the log4cxx system properly.

message. After a bit of t&e, I figured that the error was caused by the MikTeX components not being able to see dependencies inside the elevated user's home dir. So what I did was simply reinstalling MikTeX with my base-level account, as it doesn't require any registry access or similar admin-only components. The dependencies are then placed in a readable directory.

Maybe this helps someone messing around with MikTeX on a corporate machine. :-)

1
  • I had the same problem, but my solution was the opposite. After following the direction on the site suggested by @Jethro Belle, I had to run mpm as sudo, and then this error did not happen [though another one did-- I had to troubleshoot it instead :) ] – Alex Jun 6 '17 at 18:27
0

I don't know why it works, but I have experienced this twice, now, so I thought I'd share. Even though I start cmd (Win10, admin account) with admin privileges, MiKTeX throws this error and I don't seem to be able to do anything against it. But if I start the new MiKTeX console, go into admin mode, then start the command line with the icon in the lower left part of the console, I can type mpm commands without it complaining about it.


For completeness: specifically, the command I'm running in this case is

mpm --admin --verbose --require=@filename

in which

mpm starts MiKTeX package manager ...

--admin ... in admin mode ...

--verbose ... and shows what it's doing (I like to watch).

--require= is like --install=, but checks whether the package following the command is already installed. It if is, the package will be skipped

@filename: instead of a package name or a list of packages, I have a list of packages in a text file. @filename passes this list to mpm. A very handy way of installing exactly the packages that you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.