11

When using the hyperref package, I keep getting this warning that says something like:

Key ftp://ftp.ams.org/pub/tex/doc/amsmath/short-math-guide.pdf is undefined

whenever I include an http link.

For example:

\documentclass{article}

\usepackage[colorlinks=true]{hyperref}

\begin{document}

Here is a link to \href{ftp://ftp.ams.org/pub/tex/doc/amsmath/short-math-guide.pdf}{The Short
Math Guide}

\end{document}

I'm using pdflatex.exe to generate the output, and v6.82h of hyperref.sty.

18
  • 1
    Your example document works fine for me. Is that the full error message you get? What version of hyperref are you using?
    – Jake
    Aug 25 '11 at 0:49
  • I am using the MikTeX distribution, with TeXlipse as a front end
    – bobobobo
    Aug 25 '11 at 0:49
  • 4
    Your example works fine. But I can get an error ! Package keyval Error: ftp://ftp.ams.org/pub/tex/doc/amsmath/short-math-guide.pdf undefined. if I use angle brackets \href[..]{...} instead of correct braces: \href{..}{...}. So my guess is you didn't check your example but only believe that it demonstrates your real problem. Aug 25 '11 at 6:51
  • 4
    So sad this is closed, as the problem (I think from TeXlipse) persists. I use Eclipse 3.7.2 with current stable TeXlipse and latest MikTeX 2.9 under Windows. I also got those warnings. They can be eliminated (workaround) by adding \label{THE_UNDEFINED_LABEL} BEHIND \end{document} for each problem. May 21 '12 at 7:11
  • 1
    @BastianEbeling yes, the workaround wasn't working, but finally it worked, I think it was some problem with some blank space, I´m not sure cause I couldn't replicate the problem. It´s a shame that this problem still occurs on textlipse but at least your workaround solve it. Thanks
    – Dimitri
    Jul 17 '18 at 1:02
12

I guess you are using TeXLipse?

If this is the case your warnings maybe come from a bug in TeXlipse (this or this).

5
  • 4
    And the problem is not solved, yet.
    – Sven
    Aug 9 '12 at 14:10
  • 1
    I also have the problem, which was told by the originator. It seems it has nothing in common with you cited bugs. As it could be seend in the last (my) comment to the question, there is a workaroung. Could anyone please reopen the question to give me the Chance in answering with the Workaround? Thanks. Aug 20 '15 at 13:55
  • 1
    sounds interesting. I am looking forward to your answer!
    – Marcel
    Aug 20 '15 at 19:07
  • 1
    @Marcel - you can find it as the last comment to the question: bit.ly/TexlipseKeyUndef Aug 21 '15 at 20:39
  • problem not solved, yet Aug 10 '20 at 22:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.