0

I tried to install Myriad Pro as described by FontPro (XeLaTeX and LuaLaTeX aren't an option) because I couldn't build the files via cygwin and used GNU/Linux to build all necessary files and copied the files manually to my MiKTeX-directory (not the Main-directory) and I completed the installation as outlined on github. Under Linux I could compile a document without any trouble but it seemed not to work under windows... After repeating the installation (over and over) and updating MiKTeX etc. I found a wired behaviour the error doesn't appear under the standard TeX-classes but just in in Koma-Script (but not under TeX Live 2015 on Linux). And even under the koma-script-classes the file compiles if I set a \part{} (like \chapter{} or \section{}). The error seems to be linked to the font size of \chapter{} because without the chapter it compiles fine.

\documentclass{scrreprt}
\usepackage[T1]{fontenc}

\usepackage{MyriadPro}
\renewcommand{\familydefault}{\sfdefault}

\begin{document}
\part{Introduction} 
Text $\dots$    
\chapter{Introduction}
Text $\dots$


\end{document}  

Log-File:

    {C:/Users/Harry/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map}]
chapter 1.
LaTeX Font Info:    Font shape `T1/MyriadPro-OsF/bx/n' in size <10.95> not avai
lable
(Font)              Font shape `T1/MyriadPro-OsF/b/n' tried instead on input li
ne 10.
LaTeX Font Info:    Font shape `T1/MyriadPro-OsF/bx/n' in size <20.74> not avai
lable
(Font)              Font shape `T1/MyriadPro-OsF/b/n' tried instead on input li
ne 10.
! Font T1/MyriadPro-OsF/bx/n/20.74=MyriadPro-Bold- at 20.74pt not loadable: Met
ric (TFM) file not found.
<to be read again> 
                   relax 
l.10 \chapter{Introduction}

I wasn't able to read the size data for this font,
so I will ignore the font specification.
[Wizards can fix TFM files using TFtoPL/PLtoTF.]
You might try inserting a different font spec;
e.g., type `I\font<same font id>=<substitute font name>'.

! Font \T1/MyriadPro-OsF/b/n/20.74=nullfont not loadable: Metric (TFM) file not
 found.
<to be read again> 
                   \relax 
l.10 \chapter{Introduction}

I wasn't able to read the size data for this font,
so I will ignore the font specification.
[Wizards can fix TFM files using TFtoPL/PLtoTF.]
You might try inserting a different font spec;
e.g., type `I\font<same font id>=<substitute font name>'.

Missing character: There is no 1 in font nullfont!

enter image description here enter image description here

Log-file with \part:

(C:\Users\Harry\AppData\Roaming\MiKTeX\2.9\tex\latex\MyriadPro\MyriadPro-FontDe
f.sty
File: MyriadPro-FontDef.sty 2012/02/17 v0.3 font definition macros
))
\c@mv@tabular=\count96
\c@mv@boldtabular=\count97

part I.
LaTeX Font Info:    Font shape `T1/MyriadPro-OsF/bx/n' in size <10.95> not avai
lable
(Font)              Font shape `T1/MyriadPro-OsF/b/n' tried instead on input li
ne 8.
Package scrkbase Info: You've told me to use the font selection of the element
(scrkbase)             `partprefix' that is an alias of element `partnumber'
(scrkbase)              on input line 8.
LaTeX Font Info:    Font shape `T1/MyriadPro-OsF/bx/n' in size <20.74> not avai
lable
(Font)              Font shape `T1/MyriadPro-OsF/b/n' tried instead on input li
ne 8.
LaTeX Font Info:    Font shape `T1/MyriadPro-OsF/bx/n' in size <24.88> not avai
lable
(Font)              Font shape `T1/MyriadPro-OsF/b/n' tried instead on input li
ne 8.
[1

I think the behaviour seems a bit odd, does anyone have a idea? (esp. because it works under TeX Live on a Linux machine )

Update: List of the names of the files created by FontPro under GNU/Linux

ls-r

Udpate2

Running hbf2gf.exe...
hbf2gf (CJK ver. 4.8.4)

Couldn't find `MyriadPro-Bol.cfg'
miktex-maketfm: No creation rule for font MyriadPro-Bold-.

chapter 1.
! Font T1/MyriadPro-OsF/bx/n/20.74=MyriadPro-Bold- at 20.74pt not loadable: Met
ric (TFM) file not found.

By the way, at leastMyriadPro-Bol.cfg isn't created nor needed under Linux (TeX Live '15). Is it an error or something that's different in MikTeX?

Update2 enter image description here


Update3

What works best at least for me is just to use TeXlive under Windows and to create all the necessary font-files on a linux machine and copy them into the right texlive folder and than to update the texlive installation as the described by fontpro.

  • The font is definitely not installed properly. – cfr Sep 4 '15 at 2:28
  • What's preventing you from using XeLaTeX and/or LuaLaTeX? – Mico Sep 4 '15 at 5:23
  • Well, mostly the poor support of microtype (esp. for XeLaTex) but I'm using LaTeX for my Thesis and the template as well as some-packages properly won't work with LuaLaTeX (what I still use to externalize tikz-plots in my thesis). – jlk Sep 4 '15 at 12:53
1

FontPro requires tftopl.exe, pltotf.exe, vptovf.exe, and vftovp.exe. MikTeX's version does not work.

I install cygwin, install LCDF tools from w32tex distribution, and also the above 4 programs from w32tex, and then run FontPro. It works.

  • I used the FontPro scripts on a Linux machine to create all necessary font files (I updated the starting post to include them) – jlk Sep 4 '15 at 12:55
  • @harry haller: This seems to be typical of the type 1 font files not being found. Check if the fonts are mentioned in you personal/local updmap.cfg. If not, add the lines Map minionpro.map and Map myriadpro.map to the file, and in any case, run from the command line updmap --verbose (as administrator if you want all users to have access to the font). – Bernard Sep 4 '15 at 18:56
  • As I said I followed the instruction as stated on the FontPro Github site. Additionally, MiKTeX is compiling the file for different documentclasses with different font sizes! How could pdfLaTeX do this without haveing the map-file? Anyway I added an image with the result in first thread entry. – jlk Sep 5 '15 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.