0

Consider the following MNWE:

\documentclass{article}

%%% start code I can't touch
\usepackage[T1]{fontenc} 
\usepackage[utf8]{inputenc}
\usepackage{charter}                  % Serif: Bitstream Charter
\usepackage[varqu,varl]{inconsolata}  % Monospaced: Inconsolata
%%% stop code I can't touch

\usepackage{siunitx}

\begin{document}
The offset is $V_{io}=\pm$\SI{1}{\micro\volt} for $R_G$ around \SI{1}{\kilo\ohm}.
\end{document}

This will not compile (stock Ubuntu 14.04, TeXLive 2013), with the error:

! Package textcomp Error: Symbol \textohm not provided by
(textcomp)                font family bch in TS1 encoding.
(textcomp)                Default family used instead.

Now, if I comment out \usepackage{charter} it works, and if I comment out the inconsolata package will compile, although the greek mu in the unit comes out wrong.

Unfortunately, I can't change either package...

Looking around, I found that using (I can't find the Q&A again, sorry) that

\usepackage[valuemode=math,unitmode=math]{siunitx}

Makes thing compile, but again, the "µV" has a math mu...

(By the way, this gives a deprecation warning; but changing valuemode to value-mode as told in the manual gives a "option not found" error...)

How can I fix this, considering the "fixed" part that I can't touch (comes from a local template)?

  • I get no error in texlive 2015. In texlive 2013 you can convert the error to a warning with \usepackage[warn]{textcomp}. – Ulrike Fischer Sep 4 '15 at 8:48
1

Ok, obviously I found what I think is a workaround as soon as I posted it. Following this answer and adapting the symbols names (this is puzzling to me... it's a typo in the answer or really \upOmega changed to \Upomega and \textOhm to \textohm?) I can add:

\usepackage{textcomp}
\renewcommand{\textmu}{\ensuremath{\upmu}}
\renewcommand{\textohm}{\ensuremath{\Upomega}}

...and all seems to work (till now). But still I think there should be a cleaner way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.