4

I want to change the symbols of footnotes inside mdframed. I found there is quite simple solution for that, in this very very helpful answer to the same problem.

I applied it and it works but the symbols, asterinks, daggers etc, are aligned to the text and not raised as the footnotes usually are.

I tried to raise them with raisebox

\documentclass[9pt,twoside,openright,showtrims]{memoir} 
\usepackage{amsmath,amssymb,amsfonts}
\usepackage{mathspec,xltxtra}
\usepackage{url,graphicx}
\usepackage{polyglossia}

\usepackage{geometry}
\usepackage{layouts}
\usepackage{calc}
\usepackage{tablefootnote} 
\usepackage[framemethod=PSTricks,tikz]{mdframed}


\makeatletter
\AtBeginEnvironment{mdframed}{%
\def\@fnsymbol#1{\ensuremath{\ifcase#1\or \dagger\or \ddagger\or
\mathsection\or \mathparagraph\or \|\or **\or \dagger\dagger
\or \ddagger\ddagger \else\@ctrerr\fi}}%
}   
\renewcommand\thempfootnote{\raisebox{.8ex}{\small \fnsymbol{mpfootnote}}}
\makeatother

but i get errors. The asterisk is raised in the mark but i get this at the end of the frame.

enter image description here

Actually, i had the same problem even before i changed the numbering to symbols. By default, the numbering was a, b, c..., even then, they were not raised.

Do you have any ideas for a way to raise them without errors?

3
  • Welcome to TeX - LaTeX! :) I am willing to bet your problem is because you're using xltxtra: tex.stackexchange.com/a/80028. The package redefines \textsuperscript
    – cgnieder
    Commented Sep 5, 2015 at 11:13
  • wow, that was quick! you are absolutely right, i removed the xlxtra package, but now i' m wondering if something else 'breaks' without this package, that i fail to notice right now, the funny is that i can't remember why i used at first
    – user72219
    Commented Sep 5, 2015 at 11:21
  • Probably not. But to be sure you can load xltxtra with the no-sscript option if you like \usepackage[no-sscript]{xltxtra}. On the other hand: if you don't even know why you're loading it you might as well leave it out.
    – cgnieder
    Commented Sep 5, 2015 at 11:35

1 Answer 1

3

The problem isn't mdframed but xltxtra. the latter redefines \textsuperscript (and \textsubscript) to use real superior figures instead of normal figures in a smaller font size. This only works reliably if a font has the glyphs available: superscripts with xelatex? (footnotes, natbib) The package does define starred variants of both commands through which the original definitions are available.

Since the footnote mark is placed with \textsuperscript you get the problems here. One solution is to load the package with the no-sscript option.

\usepackage[no-sscript]{xltxtra}

This swaps the definitions: \textsuperscript gives the original definition, \textsuperscript* the one for the superior figures.

The other solution of course is not to use the package at all.

1
  • s/other solution/best solution/
    – egreg
    Commented Sep 18, 2015 at 12:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .