1
\documentclass[11pt,a4paper,twoside,DIV=8,BCOR=1cm,openright,parskip=never]{scrbook}
\usepackage[backend=biber,
        natbib=true,
        style=authoryear,
        maxbibnames=99,
        maxcitenames=1,
        url=false,
        isbn=false,
        doi=false,
        useprefix=false,
        backref=true,
        hyperref=true,
        firstinits=false,
        uniquename=false,
        uniquelist=false
        ]{biblatex}
\usepackage{hyperref}

\begin{document}
A, B, and C \parencite{VomBerk2010}.
\end{document}

The bibliography entry is something like

@inproceedings{VomBerk2010,
  title = {Some Awesome Title: and do not forget the colon},
  booktitle = {Proceedings of SIGCOLON},
  series = {{COL} '07},
  author = {vom Berk, Johann and Doe, John},
  date = {2007},
}

This shows up as "A, B, and C (Berk 2010)", while I expected it to render as "vom Berk". If I use the useprefix=true I get it to render as "vom Berk", but it get indexed under 'v' and not under 'B'.

And yes, that is indeed "vom", with an m.

EDIT The proposed duplicate seems to address the issue with a hack, which is far less desirable than using legitimate methods.

5
  • lockstep's answer to How can I put a name's prefix in front in citations but not in the bibliography? is a legitimate method to get what you want. It is certainly far more elegant than adding a sortname field manually. Just because there is no package option to do what you want immediately, it does not mean that four lines of code are not a legitimate solution. (In fact I think the solution is very elegant.)
    – moewe
    Sep 9 '15 at 5:48
  • I see your point, and I stand corrected. I tried the other solution, and it does not work for me, in that I get the text citation correctly (vom Berk, 2010) but the bibliography entry as "Berk, Johann vom", although sorted under 'B'.
    – Morpheu5
    Sep 9 '15 at 15:33
  • 1
    Use \makeatletter \AtBeginDocument{\toggletrue{blx@useprefix}} \AtBeginBibliography{\toggletrue{blx@useprefix}} \makeatother, then. (In \AtBeginBibliography we now have \toggletrue instead of \togglefalse). (Your question would have been a bit easier to understand if you had stated exactly what you want at the start, I think one has to read a between the lines a bit to understand what exactly it is you want.)
    – moewe
    Sep 9 '15 at 15:36
  • I just realised that the suggestion in my comment above is essentially Audrey's comment below lockstep's answer.
    – moewe
    Sep 9 '15 at 15:50
  • 1
    Maybe Biblatex handling of Dutch “van” prefix would have been a more accurate duplicate.
    – moewe
    Sep 22 '15 at 19:34
0

You could use the biblatex field sortname, i.e.

@inproceedings{VomBerk2010,
title = {Some Awesome Title: and do not forget the colon},
booktitle = {Proceedings of SIGCOLON},
series = {{COL} '07},
author = {vom Berk, Johann and Doe, John},
sortname = {Berk}
date = {2007},
}
1
  • Ah, that works. Now I just need to remember that every time I get Zotero to re-generate the bib file.
    – Morpheu5
    Sep 7 '15 at 20:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.