1

%runs in texmaker with Quickbuild = pdflex->biblatex->pdflatex(x2)->view pdf
%that makes all the citekeys hook up to the .bib file and makes ibid work and all that stuff

Adding little bit of hebrew breaks everything, simple fixes like changing \usepackage[utf8]{inputenc} to utf8x doesn't work, that one breaks biber

can you rewrite this to use polyglossia and xelatex instead of babel?

MWE:

%filename: main.tex
\documentclass[a4paper,hebrew,english]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
%\usepackage{cjhebrew}
\usepackage[hebrew,english]{babel}
\usepackage{csquotes}

\usepackage[notes,backend=biber]{biblatex-chicago}
\bibliography{sample}

\begin{document}
\title{The Chicago Citation Style with biblatex}
\author{WriteLaTeX}
\maketitle

\section{Demonstration}

laboris nisi ut aliquip ex ea commodo consequat. \autocite{Ful83}
dolor in reprehe\autocite{hello mom, Ful83}
serunt mollit anim id est laborum. \autocite{GMP81}

%\begin{hebrew}עברית\end{hebrew}
%\sethebrewעברית\unsethebrew
adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. \autocite{GMP81} 

\printbibliography

\end{document}

that file main.tex pulls from this one sample.bib to auto-complete the citekeys {Ful83} and {GMP81} and replace them with Author names and book titles. How can I type Hebrew into the main body or into the footnotes without breaking this nice Chicago template that actually works?

%filename = sample.bib
@conference{Ful83,
   author = "William Fulton",
    title = "Introduction to intersection theory in algebraic geometry",
booktitle = "Regional Conference Series in Mathematics",
   number = 54,
     year = 1983}

@inproceedings{GMP81,
   author = "Mark Goresky and Robert MacPherson",
    title = "On the topology of complex algebraic maps",
booktitle = "Algebraic Geometry Proceedings, La R\'abida,
             Lecture Notes in Mathematics",
   number = 961,
     year = 1981}
  • Sorry, what's polyphonia? Do you mean polyglossia or is this a specialised package not in TeX Live? – cfr Sep 9 '15 at 23:50
  • yes, polyglossia, let me fix that. I would love to just stay with Babel but I am also getting the font error "Jeru10" and can't find instructions to fix it since El Capitan changed the folder structure of the MacTex install. – בנימן הגלילי Sep 9 '15 at 23:57
  • This has nothing to do with Biblatex. The code doesn't compile even if you take all that stuff out. Can cjhebreweven be used to typeset Hebrew entered as unicode? Have you looked at the documentation? Its examples all seem to use transliteration. There are tables on page 3, for example. – cfr Sep 10 '15 at 0:04
2

The problem has nothing at all to do with Biblatex and I'm not sure why you would think it does. Basically, cjhebrew is not designed to input Hebrew in this format: it expects transliterated characters and not unicode. Moreover, the hebrew environment is not defined by either cjhebrew or babel with the hebrew option.

You cannot use Babel with Hebrew with XeLaTeX because babel-hebrew loads inputenc. (Babel usually works fine with XeLaTeX/LuaLaTeX.)

To switch to Polyglossia and XeLaTeX, you need something like this:

\documentclass{article}
\usepackage{polyglossia,fontspec}
\setmainlanguage[variant=british]{english}
\setotherlanguage{hebrew}
\newfontfamily\hebrewfont{Noto Sans Hebrew}[Script=Hebrew]    

\begin{document}

\section{Demonstration}

\begin{hebrew}
  עברית
\end{hebrew}

\end{document}

Note that Polyglossia does define a hebrew environment.

In the above code, you will need to change Noto Sans Hebrew to a suitable font available to you. That is just the one my font configuration software told me would work for Hebrew, so that's the one I used. Obviously, you probably have different fonts installed.

Hebrew and English

Complete code:

\begin{filecontents}{\jobname.bib}
@conference{Ful83,
   author = "William Fulton",
    title = "Introduction to intersection theory in algebraic geometry",
booktitle = "Regional Conference Series in Mathematics",
   number = 54,
     year = 1983}

@inproceedings{GMP81,
   author = "Mark Goresky and Robert MacPherson",
    title = "On the topology of complex algebraic maps",
booktitle = "Algebraic Geometry Proceedings, La R\'abida,
             Lecture Notes in Mathematics",
   number = 961,
     year = 1981}
\end{filecontents}
\documentclass[a4paper,hebrew,british]{article}
\usepackage{geometry,polyglossia,fontspec,csquotes}
\setmainlanguage[variant=british]{english}
\setotherlanguage{hebrew}
\newfontfamily\hebrewfont{Noto Sans Hebrew}[Script=Hebrew]

\usepackage[notes,backend=biber]{biblatex-chicago}
\bibliography{\jobname}

\begin{document}
\title{The Chicago Citation Style with biblatex}
\author{WriteLaTeX}
\maketitle

\section{Demonstration}

laboris nisi ut aliquip ex ea commodo consequat. \autocite{Ful83}
dolor in reprehe\autocite{hello mom, Ful83}
serunt mollit anim id est laborum. \autocite{GMP81}

\begin{hebrew}
  עברית
\end{hebrew}

adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
\autocite{GMP81}

\printbibliography

\end{document}
  • Thank you. I appreciate it. What should I tell texmaker now for quick build. Is it XeLatex-Biblatex-XeLatex ? Also, the pdf in your answer doesn't show that the footnotes are still working. – בנימן הגלילי Sep 10 '15 at 7:38
  • @paynito Thanks: I've corrected the image. I must have cut the footnotes off by mistake. XeLaTeX -> Biber -> XeLaTeX and, possibly, XeLaTeX again. You're just replacing pdfLaTeX with XeLaTeX. Biblatex is just the package - there's no executable. Either you run BibTeX (with backend=bibtex) or Biber (default). But you seem to be using Biber, which is recommended. – cfr Sep 10 '15 at 10:38
  • instructions to fix Font problem : docs.google.com/document/d/… – בנימן הגלילי Sep 16 '15 at 16:34
  • @paynito Using XeLaTeX will be easier, but if you need (pdf)LaTeX then, yes, that's the way to go as I understand it. – cfr Sep 16 '15 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.