1

How do I tell the system to treat emails and hyperlinks as a pure text and not to create hyperlinks from its contents, so that I use hyperref package commands explicitly if I want my text to be hyperlinked?

  • \usepackage[hidelinks]{hyperref} – user11232 Sep 9 '15 at 23:21
  • 1
    Welcome! Why don't you just not load hyperref and just load url so that you can format them and not have them as links. This is what I use mostly, in fact. – cfr Sep 9 '15 at 23:25
  • 1
    @Lorehead: Nope, I think it's the Reader's feature to recognize a mail adresse and changing the cursor? – user31729 Sep 9 '15 at 23:47
  • 1
    @AndrejsIgumenovs This only confirms what I said: TeXShop and Preview use the same Apple PDF libraries; both try to isolate URI from the text and there's nothing you can do. – egreg Sep 9 '15 at 23:59
  • 1
    @AndrejsIgumenovs: Can you provide the community with a minimal working example (MWE) that replicates the result? Also, include an image that shows how your reading is currently rendering content as hyperlinks. – Werner Sep 10 '15 at 0:03
4

If you don't load hyperref, LaTeX will not make hyperlinks. However, viewers such as Preview, Skim and the TeXShop one use the Apple PDF libraries and, unfortunately, try to find URL and email addresses in the text.

Compiling the simple example file

\documentclass{article}
\begin{document}
alice@bob.com
\end{document}

will show a mailto: link when the PDF is viewed with Preview or Skim, but not with Adobe Reader. I don't think it's possible to disable this annoying feature in Apple PDFKit based viewers.

  • That's true about your document. But if I remove the hyperref reference in my document, Adobe Reader still has the link. But yeah, probably it's on the viewer's side and not because of the TeX. – Andrew Igumenoff Sep 10 '15 at 0:17
0

You can use \nolinkurl on the links you want to hide.

  • 1
    Does this work for hyperlinks in the ToC, for example? – Gonzalo Medina Sep 9 '15 at 23:34
  • It does not help. – Andrew Igumenoff Sep 9 '15 at 23:37
  • hyperindex=false, hyperfootnotes=false option, I think? – Davislor Sep 9 '15 at 23:40
0

An elegant solution using hyperref

\usepackage[implicit=false, bookmarks=false]{hyperref}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.