0

I need to include one sentence in Russian to an English-only document. I use TexShop on MacOS.

I do have the following commands in my document:

\usepackage[T2A,T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[russian,english]{babel}

But I still get question marks instead of cyrillic symbols. What am I doing wrong?

  • 1
    Welcome to TeX.SX! Can you add a piece of document code that shows the issue? – egreg Sep 10 '15 at 21:49
  • Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. A suggestion: Do us a favour and change your username to something more telling than "user1234". – Martin Schröder Sep 10 '15 at 21:57
  • Btw: It's 2015 and we have two TeX-engines capable of handling Unicode and OpenType fonts (LuaTeX and XeTeX). Use one of them. – Martin Schröder Sep 10 '15 at 21:59
  • @MartinSchröder the vast majority of tex use (and almost all journal submission requirements) use pdftex, while a suggestion to try xe/lua tex might be good, The suggestion in your comment that it is wrong or outdated to be using tex seems very misplaced. – David Carlisle Sep 10 '15 at 22:05
1

In order to use encoding properly, you need to change the system encoding. Go to Preferences --> Find "Encoding" and change that to "UTF-8". That should work. Here is a screen of that: enter image description here

  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Martin Schröder Sep 10 '15 at 21:55
  • Thanks! I didn't know that Mac was using its own encodings by default. The problem is solved. – user2638514 Sep 10 '15 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.