0

I was looking to adjust some of the settings in TexShop and decided to reset my changes. I opened the 'Set Default Values' checkbox and clicked 'Regular' believing my changes would be reversed. Unfortunately it appears on installation MacTex had adjusted settings for my system and a message was displayed saying the path to the 'pdftex' command did not exist when I tried to typeset. After some investigating I found that one default path (/Library/TeX/texbin) was the one that had been set while another one (./usr/texbin) wasn't. I checked this other path and sure enough this second path existed on my system as an 'alias' (a mac feature that allows one folder to act as a 'portal' to another folder to programs that access it the alias as a folder). As such I changed my 'Path settings' '(pdf)Tex' path to './usr/texbin'. There is no longer a warning but upon pressing typeset nothing is printed in console and nothing happens. I thought maybe its because the file hasn't changed (not that this happened before) so I tried to edit the file and the program froze. I really just want to know how can I reset all the settings back to the way they were on install, not the default settings but my install settings (note, the installer of MacTex set these, not me).

1

I uninstalled TeXShop by deleting it from the Applications/TeX folder, and then I downloaded and reinstalled it. The paths were fixed and I was able to recompile without any issues. This process kept many of my settings, including my Recent Files list. Nice. This approach is probably a bit drastic (and likely has unintended consequences) but it worked for me in just a few minutes, and it let me avoid investigating and fixing the problem manually.

Note: I ran into the same problem by pressing 'Set Default Values'. In my case I was playing around with the "Source | Text and Background Colors" and "Source | Editor" settings in the TexShop -> Preferences menu. I didn't like my changes and wanted to revert them. I hadn't previously changed any of the other settings in the Preferences menu, so I figured that 'Set Default Values' would be relatively harmless. It was shocking and a bit frustrating to discover that I had ruined the paths to LaTeX and pdflatex. This is not the friendliest UI design in TexWorks, and perhaps some type of change could improve it.

| improve this answer | |
  • exactly what I did in the end my friend! :) Just forgot I ever asked! Hopefully this will help some poor soul in the future! – J-S Nov 8 '15 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.