3

Every time I try to install the full distribution of MiKTeX 2.9 under Windows XP Pro, I get the following error message.

Installation: C:\Program Files\MiKTeX 2.9
Loading package database...
starting package maintenance...
installation directory: "C:\Program Files\MiKTeX 2.9"
package repository: "C:\Documents and Settings\Vasilios\My Documents\My Downloads\MiKTeX\miktex-2.9.4250"
visiting repository "C:\Documents and Settings\Vasilios\My Documents\My Downloads\MiKTeX\miktex-2.9.4250"...
repository type: local package repository
loading lightweight database...
lightweight database digest: 33d72d9ab13255850b97edbad0e46998

An error occurred:
  source file: Libraries\MiKTeX\PackageManager\PackageInstaller.cpp
  source line: 3281
  message: The operation could not be completed because the following file failed verification:

C:\Documents and Settings\Vasilios\My Documents\My Downloads\MiKTeX\miktex-2.9.4250\hpsdiss.cab
  info: 

If it's any help, the computer I am trying to install it on is connected to the internet via a wireless interface. To obtain the distribution files, I have had to download them onto a computer connected to the internet via ethernet, and transferred them over using a memory stick.

Also, if it is any help, I downloaded the full distribution of MikTeX 2.9 from the following http server.

ctan.unsw.edu.au

Any help would be appreciated.

6
  • MiKTeX lists the Integrity of http://ctan.unsw.edu.au as Unknown. Perhaps try the Intact ftp protocol.
    – Werner
    Commented Aug 28, 2011 at 2:05
  • @Werner - I have already tried this resulting in may download failure attempts. Either there was a loss of connection with the server, or a package failed verification. Can you recommend another mirror server? Thanks!
    – Bill
    Commented Aug 28, 2011 at 2:13
  • Check out MiKTeX repositories. The problem could be a corrupt repository (hence the suggestions to change servers). As an alternative (via a similar problem as reference), install MiKTeX 2.9 using the basic installer, and update packages on-the-fly.
    – Werner
    Commented Aug 28, 2011 at 2:19
  • @Werner - Thanks, I will let you know how I go.
    – Bill
    Commented Aug 28, 2011 at 2:22
  • @Werner - Thanks for your advice! I ended up installing the basic version of MiKTeX from the ftp site as you suggested. Mind you, I did get a verification error on one of the packages while downloading, however, when I restarted the download process it ran smoothly till completion. Once again, thank you for your help.
    – Bill
    Commented Aug 28, 2011 at 5:17

2 Answers 2

2

Check out the latest MiKTeX repositories for a possible problem. The problem could be that the repository is corrupt (faulty update, incorrect checksums, etc). The solution then might be to switch to a different (intact) server, or different repository all together.

As an alternative (via a similar problem as reference), install MiKTeX 2.9 using the basic installer. Then, either update packages on-the-fly or add the packages as you need them.

1

The solution that worked for me in Windows 7 is described in the MiKTeX Sourceforge bug ticket here:

https://sourceforge.net/p/miktex/bugs/1935/

... set the MiKTeX installer to Compatibility Mode Vista.

3
  • 1
    Note, that the question was for Windows XP. You should add a remark regarding your OS.
    – Speravir
    Commented Oct 18, 2012 at 1:42
  • Hmm - you're right, I overlooked that. I guess the original question was a year ago, maybe things have changed? My experience (and others, looking around) is that Win7 (which I was referring to) has this problem, intermittently but "almost all the time". The workaround I posted has worked every time, so far. Hopefully at least my link to the miktex bug is adding value to this question/answer, for someone :) Commented Oct 18, 2012 at 21:47
  • I have Windows 7 here for some months and till today never observed this behaviour. (“Toi, toi, toi” as we say in Germany grin.)
    – Speravir
    Commented Oct 18, 2012 at 21:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .