2

I'm using eledmac/eledpar for a bilingual edition with facing pages, and would like to use more space on the left page than on the right one for the footnotes. \footnoteXmk allow me to start on the left page, but the same empty space is preserved on the right page.

eledpar footnote on the left page breaking the right page

Here is what I expected :

footnote on the left page preserving the right page space

Is \footnoteXnomk made only to balance equally the footnotes in the left and right pages ? Is there a way to do that without removing eledpar and typesetting everything by hand ?

\documentclass[a5paper,12pt]{book}
\usepackage{geometry}
\usepackage[greek,french]{babel}
\usepackage[pangram]{blindtext}
\usepackage{eledmac}
\usepackage{eledpar}
\maxhnotesX{0.4\textheight}

\begin{document}
\large
\begin{pages}

\begin{Leftside}
\selectlanguage{greek}
\beginnumbering
\pstart
\blindtext[10]\footnoteAnomk{\selectlanguage{french}\blindtext[20]}
\pend
\endnumbering
\end{Leftside}

\begin{Rightside}
\beginnumbering
\pstart
\blindtext[16]\footnoteAmk
\pend
\endnumbering
\end{Rightside}
\Pages
\end{pages}
\end{document}

I'm grateful for any ideas or suggestions.

  • Have you run your own MWE? Large font on A5 paper? (Not to mention having to load two languages I will never use.) – John Kormylo Sep 11 '15 at 15:35
  • @JohnKormylo I did this MWE to illustrate the issue, based on the related project, thanks. You could have guess that I have run it, because there is images of it actually. So yes, large font on A5 and two languages (did I mention the eledpar package ?), as a minimalist scenario of a bilingual edition on a small format. Are the pictures, rendered by this MWE, not illustrating the issue ? I don't see how your remarks, in addition to being coarse, can be relevant at all... – nliautaud Sep 11 '15 at 18:48
  • I was trying to reproduce this using paracol and wound up with 10 or so pages before the footnote started (for several more pages). Very frustrating! – John Kormylo Sep 12 '15 at 0:20
  • 1
    the main problem is that reledpar is conceptualized to put the same number of line in both left and right page. Please open an issue on github. It could be useful to add an option, but would require many test – Maïeul Sep 14 '15 at 17:29
  • 1
    I have opened an issue for this. It is a complex, but I thinks neeed, task.github.com/maieul/ledmac/issues/409 – Maïeul Sep 14 '15 at 17:53
1

The version 2.4.0 of reledpar, juste uploaded on CTAN, provides new synchronization package options.

If you want to full page, while keeping beginning of pstarts synchronized, you should use both advancedshiftedpstarts and nomaxlines option.

Read §5.2.2 for further details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.