2

The breqn documentation says (pg. 10)

• The notation := must be written with the command \coloneq. Otherwise the : and the = will be treated as two separate relation symbols with an “empty RHS” between them, and they will be printed on separate lines.

I thus tried the following.

\documentclass{article}

\usepackage{mathtools} % The \coloneq they refer to comes from here, yes?
\usepackage{breqn}     % In any case, if you remove the mathtools package,
                       % LaTeX will complain that it doesn't recognize \coloneq .
\begin{document}

\begin{dmath}
x\coloneq 2
\end{dmath}

\end{document}

While this does not throw an error per se, it does time-out (I am using ShareLaTeX (with pdfTeX), which has a time-out limit of 1 minute I believe (unless you pay)). Even if there were no limit and it would eventually compile correctly with no error, having to wait so long for even a MWE is sufficiently unacceptable as to be tantamount to an actual error. On the other hand, if you replace \coloneq with =, it compiles fine in a second or less.

What could possibly be going on? I am after all doing exactly what the documentation says to do, aren't I?

  • Yeah, that makes it compile, but the spacing is not correct inside a dmath environment (though it works in the usual AMS math environments as expected). – Jonathan Gleason Sep 11 '15 at 18:51
  • No, not at all! I appreciate the help =) – Jonathan Gleason Sep 11 '15 at 18:54
  • Did you try with \coloneqq (2q's) from mathtools? – Bernard Sep 11 '15 at 19:12
  • I did. As a matter of fact, my first guess is that it was just a typo, and so the first thing I tried was \coloneqq. When that didn't work, I thought "Well, maybe it isn't a typo after all.", and then tried \coloneq. When that didn't work just the same, after scratching my head for a bit, I came here. – Jonathan Gleason Sep 11 '15 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.