0

This is the case, when I type in:

(a)\\
\begin{table}{h!}
...
\end{table}
(b)\\
...

I hope the table appears right below (a)(I leave enough space for the table), and then below the table is (b). However, what I get now is like:

(a)
 (b)
{table I want}
{contents within (b)}

How to fix that.

  • Could you post a minimal example showing what happens? – Bernard Sep 11 '15 at 22:39
  • Environment table is float and it is not always places where someone wish with option [h!]. Instead tu use \` make empy line in edditor, It will make new paragraph and LaTeX easier put figure/table between paragraphs. Use of this option should be careful. Normally is better to use option [htb]. If like strict to have floats in desired position, use option H` which provide package float. – Zarko Sep 11 '15 at 22:43
  • 3
    If you need that a tabular environment is printed just there, you don't need a caption, so no table environment either. – egreg Sep 11 '15 at 22:47
  • See queastionhttp://tex.stackexchange.com/questions/8625/force-figure-placement-in-text. I think that your question is duplicate to this one, – Zarko Sep 11 '15 at 22:55
  • Perhaps omit the \begin{table} and stick merely with \begin{tabular}, since the latter will not "float" elsewhere on the page. – Steven B. Segletes Sep 12 '15 at 2:30
-1

Omit \begin{table} will solve the case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.