1

So I tried to use the MWE in the answer to this question.

However my output looks identical to the original post's problem.

I checked using \listfiles and my version of siunitx has cancel support. How do I get cancel and siunitx to work together?

I'm using TeXLive 2014 from the Arch repositories.

*File List*
article.cls    2014/09/29 v1.4h Standard LaTeX document class
size10.clo    2014/09/29 v1.4h Standard LaTeX file (size option)
siunitx.sty    2015/01/21 v2.6e A comprehensive (SI) units package
expl3.sty    2015/03/01 v5547 L3 programming layer (loader)
expl3-code.tex    2015/03/01 v5547 L3 programming layer
etex.sty    2015/03/02 v2.1 eTeX basic definition package (PEB,DPC)
l3unicode-data.def    2015/03/01 v5544 L3 Unicode data
l3pdfmode.def    2015/03/01 v5544 L3 Experimental driver: PDF mode
xparse.sty    2014/11/25 v5471 L3 Experimental document command parser
amstext.sty    2000/06/29 v2.01
amsgen.sty    1999/11/30 v2.0
array.sty    2014/10/28 v2.4c Tabular extension package (FMi)
l3keys2e.sty    2014/11/25 v5471 LaTeX2e option processing using LaTeX3 keys
translator.sty    2010/06/12 ver 1.10
keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
translator-language-mappings.tex
cancel.sty    2013/04/12 v2.2 Cancel math terms
translator-basic-dictionary-English.dict
siunitx-abbreviations.cfg    2015/01/21 v2.6e siunitx: Abbreviated units

closed as off-topic by egreg, moewe, user31729, user13907, Mensch Sep 12 '15 at 18:40

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Please edit in your \listflles output: 'has support' doesn't really help us. (Things certainly work with an up-to-date siunitx.) – Joseph Wright Sep 12 '15 at 6:27
  • I added the \listfiles. – PTNobel Sep 12 '15 at 16:29
  • 1
    You'll need to update siunitx: there was a bug with support for \cancel in the version you've got installed. – Joseph Wright Sep 12 '15 at 17:06
  • 5
    I'm voting to close this question as off-topic because the issue was due to outdated software and has been solved with an update. – egreg Sep 12 '15 at 17:28
0

According to this issue, there was a bug in siunitx that was fixed about a month ago.

To fix this problem while I wait for TeXLive 2015, I downloaded the zip file from the releases section the that page, and then unzipped it, ran tex siunitx.dtx, and copied the siunitx.sty and the siunitx*.cfg files into the root of my project.

  • Wait for texlive 2015? It has been out since June. – daleif Sep 12 '15 at 17:30
  • It's still in the Arch Linux Testing Repositories. It'll probably reach stable sometime in the next 2 months. – PTNobel Sep 12 '15 at 17:40
  • 1
    This is why I do not rely on getting latex through a Linux distribution. Too far behind. – daleif Sep 12 '15 at 17:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.