1

In amsart, how do you add (a hyperlink to) a personal webpage among the author's contact information?

Clearly, the proposed solution should be able to support multiple authors, just like \email.


\documentclass[10pt]{amsart}
\usepackage[foot]{amsaddr}

\begin{document}
\title[Short Title]{Long Title}
\author[Surname]{Name Surname}
\address{University}
\email{email@email.com}
\author[Surname2]{Name2 Surname2}
\address{University2}
\email{email2@email.com}
\date{14/09/2015}

\maketitle

\end{document}
7
  • Welcome to TeX.SX! Please make your code compilable (if possible), or at least complete it with \documentclass{...}, the required \usepackage's, \begin{document}, and \end{document}. That may seem tedious to you, but think of the extra work it represents for TeX.SX users willing to give you a hand. Help them help you: remove that one hurdle between you and a solution to your problem. – LaRiFaRi Sep 14 '15 at 8:41
  • 1
    What about \urladdr{...}? Does that work? – LaRiFaRi Sep 14 '15 at 8:48
  • @LaRiFaRi: Done. Thanks for the heads-up. \urladdr{...} seem to display the url at the top of the page despite the \usepackage[foot]{amsaddr}; how do I fix this? Besides, I'd like the label to be Web-page, and not URL. – user87695 Sep 14 '15 at 8:52
  • 1
    Without amsaddr it would be \renewcommand*{\urladdrname}{\itshape Web-page} to change the label. With that package, you have to do \usepackage{xpatch}\xpatchcmd{\@setaddresses}{URL}{Web-page}{}{}. Can't help you with the wrong placement. Please contact the maintainer to tell him about this (wrong) behaviour. The email-address is in the third line of his manual. – LaRiFaRi Sep 14 '15 at 9:39
  • @LaRiFaRi Thanks. In the end, I decided to remove that package because with two co-authors the footnote would become too long; and now your solution works fine. However, emailing the maintainer seems a good idea. – user87695 Sep 14 '15 at 10:45
1

You should give the command \urladdr{...} a try. But this does not seem to work with the foot option of amsaddr.

Regarding the change of label:

Without amsaddr it would be \renewcommand*{\urladdrname}{\itshape Web-page} to change the label. With that package, you have to do \usepackage{xpatch}\xpatchcmd{\@setaddresses}{URL}{Web-page}{}{}. Can't help you with the wrong placement. Please contact the maintainer to tell him about this (wrong) behaviour. The email-address is in the third line of his manual.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy