3

I'm trying to install MiKTeX on Windows 7 (32 bits) and I get this error message:

http://mirrors.tuna.tsinghua.edu.cn/CTAN/systems/win32/miktex/tm/packages/miktex-urct-bin-x64.tar.lzma (expecting 441554 bytes)...

An error occurred:
  source file: Libraries\MiKTeX\PackageManager\CurlWebSession.cpp
  source line: 465
  message: Error response from server: 404
  info: 

When I try again, I get the same error. What can I do to solve this problem?

Thanks.

  • 2
    Use another website for downloading. And restart the download with the installer program of MiKTeX. – Kurt Sep 14 '15 at 15:33
  • If you want to install a 32 bit version of MiKTeX, you certainly must not download miktex-urct-bin-x64.tar.lzma, but miktex-urct-bin.tar.lzma. – Bernard Sep 14 '15 at 18:55
  • Have you followed the two advices of MiKTeX: miktex.org/howto/install-miktex and miktex.org/howto/update-miktex ? – Kurt Sep 14 '15 at 20:11
  • I followed this website: xm1math.net/doculatex/install_miktex.html And I download MiKTeX Net Installer (32 bits) on this page: miktex.org/2.9/setup And the installer try to download x64 files, even if the file don't exist anymore on the website (and yes, I tried others mirors). – Pierre Sep 15 '15 at 8:49
1

If you want to install a version with all the packages but the .Net installer is giving you trouble, then download the basic installer. After installing MikTeX, run the Package Manager (Admin) and install all the missing packages (Edit->Select Installable Packages, then Tasks->Install).

  • I have to take the net installer because there are restrictions on my network and I cannot download big file like the basic installer. – Pierre Sep 15 '15 at 8:53
0

There is a typing error within the given link. It must be ucrt, not urct. The correct link is: https://mirrors.tuna.tsinghua.edu.cn/CTAN/systems/win32/miktex/tm/packages/miktex-ucrt-bin-x64.tar.lzma

Note that you can likely errors by repeatedly shortening the url from the right side up to the last slash character, which is not the last one in the string, until you find a functioning subsite. E. g. the first shorter version of the faulty link would be https://mirrors.tuna.tsinghua.edu.cn/CTAN/systems/win32/miktex/tm/packages/ (does already work), the next one would be https://mirrors.tuna.tsinghua.edu.cn/CTAN/systems/win32/miktex/tm/ and so on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.