Pdf viewer rotates landscape while lscape in use in this far-from-minimal example.

Example bellow illustrates how PDF viewer rotates page that is rotated landscape page originally.

enter image description here

As was pointed out in comments, commenting pdfpages package shows no rotation by PDF viewer of the rotated landscape page.

enter image description here

This minimal example gives expected result: rotated landscape page is not rotated in viewer.

%\usepackage{pdflscape} %uncomment this  and comment above line to see the difference

This is followup of this question with the test result : the printer prints rotated landscape page on portrait page.

What causes undesired behaviour, actually behaviour of pdflscape?

A note: This question seeks the same information and is unanswered as well.

  • 2
    pdfpages package can do this.
    – touhami
    Sep 15, 2015 at 6:18
  • Yes, pdfpages package causes it. How to prevent it from doing this will be probably a topic of another question :).
    – chejnik
    Sep 15, 2015 at 6:24
  • 1
    if you see the page rotated in the viewer from lscape then it is almost always just rotated in the view by the viewer (usually they have a menu option to turn off auto-rotate) there is nothing can do in lscape as it isn't doing anything, it is just the viewer being "smart" and spotting enough sideways text (which is why the minimal example doesn't rotate" pdflscape adds commands to force the rotated view so there you see it also in the minimal example. Sep 15, 2015 at 7:01

1 Answer 1


In correspondence with Andreas Matthias was pointed out:

Pdfpages is loading pdflscape.sty internally. And pdflscape rotates all landscape pages.

As a quick workaround, please add the following after loading pdfpages. This disables pdflscape to rotate the pages.


Now the behaviour is as expected.

  • pdfpages package is now updated, everything's fine.
    – chejnik
    Sep 22, 2015 at 17:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .