9

I am new to Latex and have been allowed to copy a LaTeX project in order to reuse it as a template for my thesis.
I initially adjusted most the project's content and structure for my own thesis. The project compiled fine and a PDF file was created.

Then I did some other changes: changed the name of the file frontpage.tex to titlepage.tex, changed a graphic in the titlepage.tex (previously frontpage.tex), and tried to rename \begin{titlingpage} (and \end) in the titlepage.tex to something else - these changes did not compile so I have tried to undo my changes.

But now I get the following error:

PdfTeX error: pdflatex (file ecbx0800): Font ecbx0800 at 600 not found 
==> Fatal error occurred, no output PDF file produced!

and no PDF file is created.

When I look in my Miktex folder (C:\Program Files (x86)\MikTeX 2.9\fonts\...) the following files are available in sub folders: ecbx0800.tfm and ecbx0800.mf, so I don't understand why the error occurs.

It seems that the following questions might be related to my question
Getting strange error with MiKTeX when trying to use “kpfonts” package
and
Error “Font ptmr8r at 480 not found”
but I normally use Word on my Windows 7 computer and I don't understand the solutions/explanations proposed - or whether they could solve my problem - so help solving my error creating the PDF file will be very much appreciated.

PS: I have tried copying the original Latex project again to another folder in my computer, but when I try to compile the project a similar error occurs. The file/font name has changed from ecbx0800 to ecrm0800.

  • you shouldn't be getting that error message but adding \usepackage{lmodern} will switch to a more or less compatible font set that probably avoids the errors you are getting. – David Carlisle Sep 15 '15 at 16:25
  • @DavidCarlisle Thank you! Adding the package worked, so now I have a PDF file again :) My template looks fine, but since I am new to this, I am not aware of what I have switched from by adding this package or possible consequences - might the adding of the package have any other effects than just allowing the creation of the PDF file? – Janne Sep 16 '15 at 9:26
5

You shouldn't be getting that error message but adding

\usepackage{lmodern}

will switch to a more or less compatible font set that probably avoids the errors you are getting.


You asked in comments for details of what exactly this changes:

The original extension of the TeX computer modern fonts to 8bit encodings were the "EC" fonts, and these are the latex default fonts if you use

\usepackage[T1]{fontenc}

Like computer modern, these were originally metafont fonts used as bitmap fonts in any generated pdf (and so look horrible and jagged in acrobat). There are however scalable (type 1) versions of these, using the same metrics..

So there are a couple of things wrong with your installation but a bit hard to debug at a distance.

If you specify (in your font map configuration) that you want the original metafont versions, then metafont is supposed to start and generate the font, not stop with a font not found error. But..

The configuration is supposed to say that these fonts are available in type1 form already, and so not try to generate them with metafont by default.

Perhaps someone who has used miktex could point you to the right configuration options there, but meanwhile..

latin modern is a newer far more extensive interpretation of the computer modern design, available in type1 (for pdftex) but also covering more of teh unicode range in open type format (for xetex luatex or any other modern non-tex system that wants that look) It is the default font if you use fontspec with xelatex or lualatex. So basically it looks the same as computer modern/ec but it is in fact a completely different font set, and there may be minor differences in letters and spacing (but the metrics for spacing are I think the same in the T1 encoding range)

So depending on your time and priorities you could track down what's wrong with your ec configuration, or you could just use latin modern and forget about it....

  • Thanks @david-carlisle for the hint and background information. I had better results with \usepackage{times}, in lmodern the math display (allign, equation) misses various characters. I have the encoding at T1 and also used newtxtext and newtxmath. Both times and lmodern get rid of the error. – Georg Jung Jul 19 '17 at 9:25
  • for me, it was solved by the explanations in tex.stackexchange.com/questions/280631/… – LFH Oct 30 '18 at 13:37
1

I was experiencing this very problem with the package dgruyter.sty.

The problem went away after I installed the package cm-super (I'm in Linux)

-3

This error can be fix in Windows if you run the following command in Command Prompt:

initexmf --mkmaps 
  • 1
    Welcome to TeX.SX! Could you please elaborate on how this solves the question? – TeXnician Feb 23 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.