I run WinEdt 5.4. I usually use the button TeXify and sometimes PDF LaTeX to create my texts. When doing it WinEdt creates a lot of auxiliary files. I don't want to erase them all the time because I know the program needs them. However, I would like to have WinEdt create all this auxiliary files in different folder and not on the main one. I have found in another question that for PDF LaTeX one has to use the command

pdflatex -aux-directory=/some/temp/dir

However, I do not know where to place that command and neither what to do for TeXify. So my questions are

Question 1: Where do I have to put the above command to make it work on PDF LaTeX?

Question 2: Is there an analogue command for TeXify? If so, which command it is and where do I put it?

Thank you very much

Edit: Bernard's answer shows me I have to add a screenshot of my menu, since in current WinEdt 9.1 it is direct Here goes my menuExectution Mode Menu on WinEdt5.4

closed as off-topic by Kurt, Paul Gaborit, user31729, user13907, Zarko May 5 '16 at 0:23

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Nope, I can't update since I am too close to submitting my PhD. Afterwards, I'll definitely. I use MikTex 2.9 – Tintin Sep 17 '15 at 16:35
  • 4
    I'm voting to close this question as off-topic because the used version of the op is 5.4, the current version of winedt is 10 and the op does not react any more ... (Too localised) – Kurt May 4 '16 at 22:46

I don't remember the details about WinEdt 5.4, but I think it was not that different from today's (WinEdt 9.1!): you should have an Execution Modessubmenu in the Options menu. Select the TeX Options tab. The is an edit window the the TeX Auxiliary Output folder, like this:

enter image description here

Hope this helps, but really you should upgrade!

  • Thanks a lot Bernard. I have added a picture of my WinEdt's menu, I dont have such a box clearly displaying the Auxiliary folder. Do you have any sugestion? By the way, you are totally right, I definitely should upgrade, but my PhD defense is too close to make such a change now :) – Tintin Sep 17 '15 at 16:44
  • You can install side-by-side, and in case of problems, return to version 5.4. Btw WinEdt now uses utf 8 encoding. For a possible solution try adding the following switch to the console applications (I remember there was an editing windows, per application, where one could enter switches; it is now under the ‘Console applications’ tab: --aux-directory=TeXAux, or maybe ./TeXAux. You will have to create the directory by hand (nowadays this is done by WinEdt). – Bernard Sep 17 '15 at 19:11
  • Wait Bernard, I don't follow you :) Let me see: As you can see in the image I putted on the Question, there is Switch box for LaTex, Tex, Texify, etc I added your command (the two versions) to these three and created the folder where the .tex file was. However it didnt compile since TexIfy didin't reconize the command. I remove it from Texify, then compiled. It worked, but WinEdt still created the auxiliary files. Still, thank you very much – Tintin Sep 18 '15 at 11:20
  • It's my turn no to understand: you want there is no auxiliary files at all? I thought you wanted them to be hidden in an Aux subdirectory. It I interpret well, I think it is impossible. Anyway, all these files are not created by WinEdt, which is but a specialised editor. It is the compiler that creates them, and they're needed for the table of contents, cross references, &c. – Bernard Sep 18 '15 at 11:37

WineEdt support TeXAux subdirectory where it store all auxiliary files except .synctect (if you use backward search mechanism). Just create it in your working directory. This support is present after WinEdt 6 (as far as I know). Upgrade from 5.4 to recent WinEdt is not free, but it worth to do this. Its user interface is the same.

Not the answer you're looking for? Browse other questions tagged or ask your own question.