3

There are a few questions already about minitoc. But I could not find a way to suppress/disable the "Contents" title of the minitoc and the hrules...

MWE:

\documentclass{report}

\usepackage{minitoc}

\dominitoc

\begin{document}

\faketableofcontents

\chapter{Chapter One}

The following topics will be explored:
\minitoc

\section{Section One One}
\subsection{Subsection One One One}
\subsection{Subsection One One Two}


\end{document}

screenshot

3
  • \mtcsettitle{minitoc}{} sets an empty title (i.e. no title)
  • \mtcsetrules{*}{off}, all rules in the various ToCs are disabled then.
  • If the minitoc is too much to the right margin, use \mtcsetoffset{minitoc}{-4.0em} then (change -4.0em to some value at will)
  • If mtcsetoffset isn't the right tool, use \setlength{\mtcindent}{-1.5em} instead, which sets the indentation of the toc as well. (-1.5em again being a pure guess value here)

\documentclass{report}

\usepackage{minitoc}

\dominitoc

\mtcsettitle{minitoc}{}
\mtcsetrules{*}{off}
%\mtcsetoffset{minitoc}{-4.0em}  % To shift the minitoc to the left, if needed!
\setlength{\mtcindent}{-1.5em}
\begin{document}

\faketableofcontents

\chapter{Chapter One}

The following topics will be explored:
\minitoc

\section{Section One One}
\subsection{Subsection One One One}
\subsection{Subsection One One Two}


\end{document}

enter image description here

  • The ToC is indented too much, in my opinion – user31729 Sep 18 '15 at 10:55
  • I am using an one-depth minitoc (\setcounter{minitocdepth}{1}), and would like to not have indentations in the sections. This is not working for me: \setlength{\stcindent}{0pt}. The problem with \mtcsetoffset is that it moves the entire minitoc (including pages) to the left. Do you know how I could just disable the indentation? (many, many thanks btw!) – Ricardo Cruz Sep 18 '15 at 11:12
  • @RicardoCruz: I'll try, give me some time – user31729 Sep 18 '15 at 11:14
  • @RicardoCruz: See the update. \stcindent is only available in a secttoc which conflicts with report.cls, as far as I have understood the manual/error messages of the package – user31729 Sep 18 '15 at 11:37
  • Perfect! I had to do a combination between \mtcindent and \mtcsetoffset because \mtcindent would enlarge the minitoc ... But it is just as I wanted now! Thank you! – Ricardo Cruz Sep 18 '15 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.