16

I'm struggeling with the same error described in this post Problems on Latex Compiler Errors. Here's an MWE

\documentclass{scrartcl}
\usepackage{glossaries}
\begin{document}
Lipsum
\end{document} 

which produces the error

! LaTeX Error: File `mfirstuc.sty' not found.

(see complete log-file)

Last week I updated packages (as user and admin), but got an "update l3kernel..." error message afterwards when trying to compile an MWE (Miktex, TeXStudio, pdflatex). After deinstallation of Miktex and reinstallation everything worked fine until I tried to use glossaries.

Update:

After the synchronization (thanks Ulrike!) the installation worked for mfirstuc.sty, but now glossary-hypernav.sty can't be found

! LaTeX Error: File `glossary-hypernav.sty' not found.

(see updated log-file for details)

  • 1
    Welcome to TeX.SX! Nicola Talbot (the author of glossaries) changed the package last week, splitting off the mfirstuc package from the glossaries bundle. Try to install that packages separately – user31729 Sep 18 '15 at 11:39
  • 6
    Synchronize your local package databases in the package managers (user + admin) with menu repositories ->synchronize. – Ulrike Fischer Sep 18 '15 at 11:53
  • I am also encountering the same problem (LaTeX Error: File `glossary-hypernav.sty' not found.): have you found any solution? thank you – user88162 Sep 21 '15 at 9:13
18

I had the same problem. I followed Ulrike's advice i.e. Synchronization of the local package databases (thanks Ulrike!!). It sorted out the initial issue.

Next I too ended up with the "glossary-hypernav.sty" not found error. I then went to Start-> All Programs -> MikTex 2.xx -> Maintenance(Admin) -> MikTex Package Manager (Admin) and scrolled down to glossary. I single-clicked on that, then on the plus (+) sign at the top of the window to add that package and it's all working now.

Thank you very much Ulrike for setting me on the right path - I had tried the second step several times with no result; the synchronisation was needed first.

(Forgot to add that before doing any of the above, as part of my efforts at trying to solve the problem I downloaded a copy of the "mfirstuc.sty" file and added it to my "C:\Program Files (x86)\MiKTeX 2.9\tex\latex\glossaries\base". However, I don't think this makes any difference.)

  • 1
    Thanks, that works :) After manually installing glossary and glossaries using MikTex Package Manager (Admin) everything is compiled without an error. – BarbaraB Sep 22 '15 at 8:42
  • 4
    It is critical to do the synchronize in the Package manager after downloading the package. – user2600959 Oct 22 '15 at 2:03
  • can you take @user2600959 comment into your answer. This indeed is very critical. – Ratnanil Jul 24 '16 at 8:40

protected by Community Nov 18 '15 at 7:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.