2

When using the footmisc package it causes many PdfTeX errors in my thesis:

pdfTeX warning (dest): name{Hfootnote.1} has beend referenced but does not exist, replaced by a fixed one

Here is a MWE:

\documentclass[12pt, oneside]{Thesis}

\usepackage[backend=biber, autocite=footnote, citestyle=authoryear-icomp, bibstyle=authoryear]{biblatex}
\usepackage[bottom, hang]{footmisc}
\usepackage{filecontents}

\begin{filecontents*}{jobname.bib}
    @book{SomeSource,
        author = {The Author},
        year = {2015},
        title = {The Title}
    }
\end{filecontents*}

\addbibresource{jobname.bib}

\begin{document}
Some Text.\autocite[][123]{SomeSource}{}
\printbibliography[]
\end{document}

I found several posts saying, that one should load the hyperref package after all other packages, but whether or not I load the package and regardless of the position within the code, the issue remains.

An idea anyone?

BTW: I'm using the versions hyperref.sty 2012/11/06 v6.83m Hypertext links for LaTeX and footmisc.sty 2011/06/06 v5.5b a miscellany of footnote facilities.

8
  • If I use \usepackage{hyperref} after \usepackage[bottom, hang]{footmisc}, I don't get that warning.
    – user11232
    Sep 20, 2015 at 9:51
  • @Harish: Do you get the warning without adding hyperref? Because I just tried it again fearing I made this post for nothing - but still the same behaviour. Could it be that any other configuration is wrong?
    – Wrstkpp
    Sep 20, 2015 at 10:00
  • Without hyperref, no warning! You can try updating or deleting the aux file.
    – user11232
    Sep 20, 2015 at 10:03
  • Deleted the aux file - without effect.
    – Wrstkpp
    Sep 20, 2015 at 10:08
  • Did you compile more than once without changinf the document? Normally this messages disappear then. Sep 20, 2015 at 12:29

1 Answer 1

3

The problem with your used document class MastersDoctoralThesis is that it defined already the call of hyperref. If you add \usepackage[hyperfootnotes=false]{hyperref} you get an option class clash error for package hyperref.

Just use \PassOptionsToPackage{hyperfootnotes=false}{hyperref} in the line before \documentclass (see line 11 of MWE). With this command you can advice LaTeX to add the given option hyperfootnotes=false to package hyperref when it is called.

See the corrected MWE (I added the missing packages you left out):

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{SomeSource,
  author = {The Author},
  year   = {2015},
  title  = {The Title},
}
\end{filecontents*}


\PassOptionsToPackage{hyperfootnotes=false}{hyperref}
\documentclass[%
  english,
  12pt, 
  oneside
]{MastersDoctoralThesis}

%\usepackage[english]{babel}
\usepackage{csquotes}

\usepackage[%
  backend=biber, 
  autocite=footnote, 
  citestyle=authoryear-icomp, 
  bibstyle=authoryear
]{biblatex}
\addbibresource{\jobname.bib}

\usepackage[bottom, hang]{footmisc}
%\usepackage[hyperfootnotes=false]{hyperref}


\begin{document}
Some Text.\autocite[][123]{SomeSource}{}

\printbibliography[]
\end{document}

To test just comment out line 11 and delete the % in line 30: your warning returns ...

In the manual of package footmisc on page 7 you can read:

hyperref The hyperref package has ambitions to make hyperlinks from footnote marks to the corresponding footnote body; naturally this causes grief to footmisc, and unfortunately no remedy is currently known. If you use foot- misc, suppress hyperref's hyper-footnotes, by loading it as: \usepackage[hyperfootnotes=false,...]{hyperref} Further work on the interaction between the two packages is proposed, but not yet scheduled.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .