0

Does anyone have an idea as to why my bibliography is rendered in this way (see image)? This happens to all @article entries.

Strange Quote Behavior

The .bib entry is

@ARTICLE{MNIST,
author={Lecun, Y. and Bottou, L. and Bengio, Y. and Haffner, P.},
journal={Proceedings of the IEEE},
title={Gradient-based learning applied to document recognition},
year={1998},
month=11,
volume={86},
number={11},
pages={2278-2324},
doi={10.1109/5.726791},
ISSN={0018-9219}}

I am using cleanthesis.sty with the defaults (bibtex), editing with Texmaker on Windows.

  • 1
    It is because you, some package you are loading, or cleanthesis.sty (not cleanthesis.cls?) is likely loading a language module like german for either babel or polyglossia. – jon Sep 21 '15 at 5:46
  • Welcome to TeX.SX! Can you be a bit more precise about what you object to in the output. I can't see a broken quotation mark. (They are not your standard English/American quotation marks though, they look like the ones used in German amongst other languages.) What I think a bit meh is the space between the label and the entry which is almost non-existent. But to change that we would need to know more about your document, to that end a MWE would be extremely helpful. – moewe Sep 21 '15 at 6:36
  • Yes, you are both correct, it was loading csquotes with german. Thanks to both of you! – absolutelyNoWarranty Sep 21 '15 at 8:28
1

The solution is to remove the german-style quotes option.

In cleanthesis.sty

\RequirePackage[                    % advanced quotes
    strict=true,                    %   - warning are errors now
    style=german                    %   - german quotes
]{csquotes}

to

\RequirePackage[                    % advanced quotes
    strict=true,                    %   - warning are errors now
    style=english                   %   - english quotes
]{csquotes}
  • I'd rather say that the solution would be avoiding such a rigid style or, at least, asking its author to fix the language dependences of the style. – egreg Oct 22 '15 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.