2

Should I be using fontspec per Single quotes in csquotes enter image description here ? My initial single quote faces the wrong way, latex thinks it's an apostrophe.

MWE: filename: mwe-singlequotes.tex

\documentclass[a4paper,hebrew,british,12pt]{report}
\usepackage{geometry,polyglossia,fontspec,csquotes,setspace}
\geometry{vscale=.85} %default is .7, bottom margin too big
\MakeOuterQuote{"}
\setmainlanguage[variant=british]{english}
\setotherlanguage{hebrew}
\newfontfamily\hebrewfont{Times New Roman}[Script=Hebrew]
\usepackage[notes,backend=biber,bookpages=false,doi=false,isbn=false,labeldate]{biblatex-chicago}
%makes block quotes single spaced
\newenvironment*{singlespcquote}
{\begin{spacing}{1}\quote}
{\endquote\end{spacing}}
\SetBlockEnvironment{singlespcquote}
\SetBlockThreshold{0}
\begin{document}
\section*{Initial 'single quote' is backwards}
\doublespace
I am having trouble with, "single quotes, said the 'latex user' to his     'friend.'"  
The first one is back wards.  \texthebrew{".הראשון הוא חזרה מחלקות"}  Oh no, I just discovered that Hebrew quotes are wrong.  Let me try this "\texthebrew{הוא}"  Ok, that's a 'stopgap'

\blockquote{I reached a point towards the end on the old heart where I had trouble getting out of a chair. All I wanted to do was get out of bed in the morning and walk to my office and sit back down in the chair. Now I throw 50 pound bags of horse feed in the back of my pickup truck and I don't even think about it. I'm back doing those things.}

Well I don't know when to use blockquote vs. displayquote.  Please don't try to fix my backward initial single quote by putting me on babel/pdflatex instead of polyglossia/xelatex.  I think I'm on csquotes insteads of quotes or quoting for a reason, but I don't know it any more.  This document compiles with \$latexmk -xelatex -f mwe-singlequotes.tex
\end{document}
  • Wow, problem is actually somewhat related to auto-complete (auto-close?) features in SublimeText. I was hitting single quote ' and being given two ' ' with the cursor placed in between. This makes the first one backwards after compilation. By hitting ` instead I am actually given ` ' with the cursor in between and it compiles to correctly to pretty-curly-single quotes. – בנימן הגלילי Sep 21 '15 at 9:01
2

Using "inverted" when you start a single quote part should work:

`text'

MWE:

\documentclass[a4paper,hebrew,british,12pt]{report}
\usepackage{geometry,polyglossia,fontspec,csquotes,setspace}
\geometry{vscale=.85} %default is .7, bottom margin too big
\MakeOuterQuote{"}
\setmainlanguage[variant=british]{english}
\setotherlanguage{hebrew}
\newfontfamily\hebrewfont{Times New Roman}[Script=Hebrew]
\usepackage[notes,backend=biber,bookpages=false,doi=false,isbn=false,labeldate]{biblatex-chicago}
%makes block quotes single spaced
\newenvironment*{singlespcquote}
{\begin{spacing}{1}\quote}
{\endquote\end{spacing}}
\SetBlockEnvironment{singlespcquote}
\SetBlockThreshold{0}
\begin{document}
\section*{Initial `single quote' is backwards}
\doublespace
I am having trouble with, "single quotes, said the `latex user' to his     `friend.'"  
The first one is back wards.  \texthebrew{".הראשון הוא חזרה מחלקות"}  Oh no, I just discovered that Hebrew quotes are wrong.  Let me try this "\texthebrew{הוא}"  Ok, that's a `stopgap'

\blockquote{I reached a point towards the end on the old heart where I had trouble getting out of a chair. All I wanted to do was get out of bed in the morning and walk to my office and sit back down in the chair. Now I throw 50 pound bags of horse feed in the back of my pickup truck and I don't even think about it. I'm back doing those things.}

Well I don't know when to use blockquote vs. displayquote.  Please don't try to fix my backward initial single quote by putting me on babel/pdflatex instead of polyglossia/xelatex.  I think I'm on csquotes insteads of quotes or quoting for a reason, but I don't know it any more.  This document compiles with \$latexmk -xelatex -f mwe-singlequotes.tex
\end{document}
  • I'm typing mostly in sublime text on a mac. It's a monospaced font that makes all quotes look like straight quotes not curly quotes. tex.stackexchange.com/questions/50711/… suggests TeXShop does some magic to your quotes as you type them. – בנימן הגלילי Sep 21 '15 at 8:31
  • Is your "inverted" the backtick under the tilde? ~ ? So I should open all single quotes with a back tick? – בנימן הגלילי Sep 21 '15 at 8:32
  • @paynito I use an azerty keyboard. In this case it done with alt gr + 7. On other keyboard I don't know – Romain Picot Sep 21 '15 at 8:39
2

Your outer quotes work because of the \MakeOuterQuote declaration. You can make a similar declaration for the inner quotes, but you can't use ' as csquotes protects it (you would run into problems with apostrophs). The "accent aigu" would work, but I would prefer to use the csquotes commands

\documentclass[a4paper,12pt]{report}
\usepackage{polyglossia,fontspec}
\usepackage{csquotes}
\MakeOuterQuote{"}
\MakeInnerQuote{´}
\setmainlanguage[variant=british]{english}
\begin{document}
I am having trouble with "single quotes, said the ´latex user´ to his friend"

I am having trouble with \enquote{single quotes, said the \enquote{latex user} to his friend}
\end{document}

enter image description here

Using a backtick like suggested by Romain will give the correct quote too but doesn't make use of the csquotes features and don't adapt when you change the language.

  • c'mon it's only an accent aigu or accent grave on top of a letter, by itself it's a backtick, like (forward) slash and backslash, computer words must follow American usage Q.E.D. – בנימן הגלילי Sep 21 '15 at 8:48
  • @paynito: I know that the grave accent is called backtick when used alone, But I have no idea how the accent aigu is called. And if you only want answers from native americans, I don't mind to ignore you in the future. – Ulrike Fischer Sep 21 '15 at 9:00
  • You should be able to type both accents alone by hitting space instead of some char after option-e, at least that is how it works on my keyboard. – Ulrike Fischer Sep 21 '15 at 9:11
  • `h' can be <option-e> <spacebar> h ' or <option-e> h ' the 2nd would give é' not `e' so I'm leaning toward ` as \openSingleQuote and → to exit the auto-closed single quotes. – בנימן הגלילי Sep 21 '15 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.