3

I have an "illogical" overfull warning under pdflatex+biblatex+memoir. Illogical because page range don't make sense and it happens at \end{document}. The warning is: Overfull \hbox (83.28351pt too wide) in paragraph at lines 3546--291 83 point is a lot, but nothing appear strange on the final output, even with \overfullrule=5pt

Line 291 is: \end{document} and the only file with more than 3546 lines is .aux and this line is: \abx@aux@number{225}{Honegger-Fresco1993}{0}{nyt}{1} The first line related to bibliography.

The relevant piece of logfile is:

Package atenddvi Info: Last page = 88.
 [82]
\tf@toc=\write7
Package atveryend Info: Empty hook `BeforeClearDocument' on input line 291.
Package atveryend Info: Executing hook `AfterLastShipout' on input line 291.
 (tesi.aux)
Package atveryend Info: Executing hook `AtVeryEndDocument' on input line 291.
Package atveryend Info: Executing hook `AtEndAfterFileList' on input line 291.
Package rerunfilecheck Info: File `tesi.out' has not changed.
(rerunfilecheck)             Checksum: C9EB163FC90A78187E3A4EF49264197F;2434.
Package logreq Info: Writing requests to 'tesi.run.xml'.

Overfull \hbox (83.28351pt too wide) in paragraph at lines 3546--291
\T1/XCharter-TLF/m/n/10.95 (-15) 89 90 91 92 93 94 95 96 97                    

                                                                              |

 []

 ) 
Here is how much of TeX's memory you used:

Also what are these empty lines, the pipe and the closing parenthesis?

I'm trying to create a MWE, but it is still too big.

Should I ignore this warning (as I'm doing) or is there anything I can learn and improve? Thanks a lot!

  • Interestingly, if I produce overfull boxes in my bibliography, I get a warning for one line after the \printbibliography command (which might well be the \end{document} line). As such we then only know that the problem is somewhere in the bibliography. Is there any chance of you being able to isolate the problem into a MWE? – moewe Sep 24 '15 at 7:17
  • 1
    It seems that the overfilling is caused by the back references. – egreg Sep 24 '15 at 7:23
  • One further observation I made is that, in my trials at least, the overfull boxes in the bibliography appeared before the Package atveryend Info block in the .log. Which leads me to suspect it might be something else and not the bibliography. – moewe Sep 24 '15 at 7:25
  • \showboxbreadth=\maxdimen\showboxdepth=\maxdimen can be added to get more details about the contents of the overfull box. – Heiko Oberdiek Sep 24 '15 at 7:39
  • Thanks Heiko! If I interpret correctly, seems it is outputting page numbers after the last page and then 170 identical lines: .\glue 3.04408 plus 1.52203 minus 1.01506 – SiliconValley Sep 24 '15 at 12:02
2

Because you gave not an proper MWE it is hard to help you.

At last I can not recreate your error but in your given bib file I found one problem that---I guess---causes your problem.

I have the following MWE (based on your given files, reduced a little bit and added two \cite commands to have a proper compiling and using package filecontentsto include two bib entrys):

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@Book{Merleau-Ponty1945,
  Title      = {Phénoménologie de la perception},
  Author     = {Maurice Merleau-Ponty},
  Date       = {1945},
  Location   = {Paris},
  Publisher  = {Éditions Gallimard},
  Series     = {Bibliothèque des Idées},
  Langid     = {french},
  Options    = {skipbib=true},
}
@Book{Merleau-Ponty2003,
  Title          = {Fenomenologia della percezione},
  Author         = {Maurice Merleau-Ponty},
  Date           = {2003},
  ISBN           = {9788845253560},
  Publisher      = {Bompiani},
  Langid         = {italian},
  Related        = {Merleau-Ponty1945},
  Relatedstring  = {Orig.},
}
\end{filecontents*}


\documentclass[%
  11pt,a4paper,extrafontsizes,
  french,
  english,
  italian
]{memoir}

\usepackage[%
  french,
  english,
  italian
]{babel}
\usepackage{XCharter}                       %% per i testi Bitstream Charter con in più i font Small Caps
\usepackage[T1]{fontenc}                    %% usa la codifica che supporta le lettere accentate
\usepackage[utf8]{inputenc}                 %% codifica dei testi (va dopo fonts e fontenc)
\usepackage[autostyle]{csquotes}            %% richiesto da biblatex
\usepackage[%
  style=authoryear,
  language=auto,
  backend=biber,
  firstinits=true,
  uniquename=init,
  defernumbers=true,
  isbn=false,
  eprint=false,
  urldate=comp,
  sorting=nyt,
  safeinputenc=true,
  bibencoding=utf8,
  clearlang=true,
  maxcitenames=1,
  mergedate=basic,
  block=space,
  autolang=other
]{biblatex}             %% gestione della bibliografia

\urlstyle{sf}
\usepackage{hyperref}                                   %% create hyperlinks and metadata in PDF 

%%% Page size
\semiisopage
\linespread{1.05}       %% Suggested for Charter

%%% Adjust bibliographic entries
\DeclareFieldFormat[article]{volume}{\bibstring{volume}~#1}
\DeclareFieldFormat[article]{number}{\bibstring{number}~#1}
\renewbibmacro*{volume+number+eid}{%
  \printfield{volume}%
  \setunit*{\addcomma\space}%
  \printfield{number}%
  \setunit{\addcomma\space}%
  \printfield{eid}}

\makechapterstyle{thesisChapterStyle}{
    \chapterstyle{default}
    \renewcommand*{\beforechapskip}{15pt}
    \renewcommand*{\chaptitlefont}{\normalfont\Huge\bfseries\sffamily\raggedleft}
    \renewcommand*\printchaptername{}
    \renewcommand*{\chapnumfont}{\normalfont\bfseries\fontsize{100}{130}\selectfont\raggedleft}
}
\chapterstyle{thesisChapterStyle}

\checkandfixthelayout

\addbibresource{\jobname.bib}
\showboxbreadth=\maxdimen\showboxdepth=\maxdimen %more info about overfull box


\begin{document}
 \cite{Merleau-Ponty1945}% Options = {skipbib=true} in bib entry
\cite{Merleau-Ponty2003}

\backmatter
\printbibliography 
\end{document} 

That results with the following warning:

pdfTeX warning (dest): name{cite.0@Merleau-Ponty1945} has been referenced but does not exist, replaced by a fixed one

The reason for that is found in the bib entry, see Options:

@Book{Merleau-Ponty1945,
  Title      = {Phénoménologie de la perception},
  Author     = {Maurice Merleau-Ponty},
  Date       = {1945},
  Location   = {Paris},
  Publisher  = {Éditions Gallimard},
  Series     = {Bibliothèque des Idées},
  Langid     = {french},
  Options    = {skipbib=true}, %<========================================
}

Now LaTeX writes the citation of this book into the dokument, but it is not allowed to add it to the bibliography. But LaTeX wants to link to it ...

And this done several times in your documents results in your problems ...

Here the cites in text:

enter image description here

and the resulting simple bibliography:

enter image description here

If you comment the line \cite{Merleau-Ponty1945} the warning is gone.

The solution for you? I guess deleting this Options in the bib file or do not cite them in your work ...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.