How do I create a format file?

I've successfully compiled the TexLive sources under Ubuntu. Unfortunately, there seemed to be no included format files (e.g., plain.fmt, pdftex.fmt, luatex.fmt, etc.). So, to create one, I tried the following commands, but neither produced an "fmt" file:

tex -ini plain.tex

tex -ini '\input plain \dump'

I also tried the instructions in this link to no avail


Compiling my own mktexfmt

By the way, I've created a directory that conforms to TDS, as well as the texmf.cnf file. I've done this before under Windows years ago, and I was able to generate both plain.fmt and latex.fmt. But I can't do the same under Ubuntu.

closed as unclear what you're asking by Mike Renfro, Stefan Pinnow, Mico, Zarko, Mensch Nov 27 '16 at 19:49

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    If you've compiled TeX Live from the sources, you should have fmtutil available and be able to do fmtutil-sys --all: does that work? What do you actually get from tex -ini plain.tex: 'doesn't work' is a bit vague. (Aside: I also wonder why you are compiling from the source! It might be worth saying how much of TL you downloaded/compiled that way.) – Joseph Wright Sep 27 '15 at 7:29
  • @JosephWright Thanks for the comment. "fmtutil-sys" is not available; I do have the executables tex, luatex, xetex, pdftex, tangle, weave, etc., but not "fmtutil-sys". "tex -ini.." does not generate the format file; that's what I meant by "doesn't work. As for TL, I've downloaded the whole sources and compiled them because I wanted to create my own minimal distribution and modify the sources, partly out of curiosity. I don't have luck though doing it under Windows using MingW, which was my original plan. – knight_owl Sep 28 '15 at 1:04
  • @knight_owl: The sources don't install a usable system. So I'm not surprised that "it doesn't work" - what does that mean, exactly? Show us the output of the commands, please. – Martin Schröder Sep 28 '15 at 5:22
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Martin Schröder Sep 28 '15 at 5:23
  • I see you've edited but we still need some real detail, for example a .log file from TeX. – Joseph Wright Sep 28 '15 at 12:04

Browse other questions tagged or ask your own question.