4

As said above, this MWE

\documentclass{book}
\usepackage{lipsum}
\usepackage{subfig} % this breaks list of figures with overwriting labels

\begin{document}

\mainmatter
\lipsum
\begin{figure}
  \caption[Short caption for list of figures]{Long caption}
\end{figure}

\backmatter
\listoffigures

\end{document}

when compiled with pdflatex, produces the following problem:

enter image description here

whereas without subfig package everything is fine.

Any clue? Thanks in advance.

  • Your code posted above doesn't recreate the problem. – user11232 Sep 27 '15 at 10:16
  • @HarishKumar Very strange, I checked again and the problem is there, as you can see from the image I posted. I use MikTeX 2.9 and I just updated all packages, what did you use to check? – mmj Sep 27 '15 at 10:31
  • Same miktex updated 3days ago. :) : i.stack.imgur.com/0cgav.png – user11232 Sep 27 '15 at 10:36
  • Damn, now what? I also tried deleting the auxiliary files and disabling -shell-escape compiling option, problem still there. Is there any more cache I could delete? – mmj Sep 27 '15 at 10:46
4

This is a known bug which existed in the caption package for about three days. So updating your TeX distribution should help, if version 2015-09-20 (or newer) of the caption package bundle is not part of your TeX distribution yet, either wait or update the caption package bundle manually [1].

See also: https://sourceforge.net/p/latex-caption/tickets/24/

[1] https://sourceforge.net/p/latex-caption/code/HEAD/tree/branches/3.3/tex/

  • Tha package manager of my MikTeX says that caption was packaged on 2015-09-22, but al least your are giving me hope, I'll check your links. – mmj Sep 27 '15 at 11:08
  • 1
    Take a look at the logfile generated when compiling your document. The date of caption3.sty should be 2015-09-20. If it is 2015-09-17, MikTeX has picked the older, buggy version of caption3.sty, for whatever reason, maybe because of using a not-yet-updated CTAN mirror. (Unfortunately miktex.org/packages/caption does not mention the version.) – Axel Sommerfeldt Sep 27 '15 at 11:16
  • You are right, my log shows Package: caption3 2015/09/17 v1.7-111, thanks a lot for pointing out the issue in such detail. I've tried to update MikTeX from a few random servers but no one has the 2015/09/20 version of caption package, is it possible to manually update the package? How easy and trouble-free is a manual update? – mmj Sep 27 '15 at 14:08
  • 1
    Just locate caption3.sty on your hard drive and replace it with the one linked in my answer. That file is the only real difference between the caption bundle releases 2015-09-17 and 2015-09-20, so if you have 2015-09-17 installed it should be problem-free just to replace this file. – Axel Sommerfeldt Sep 27 '15 at 14:14
  • 1
    Update: It seems that MilkTeX updated the caption package on 2015-09-29, so simply updating MikTeX packages should help now. (See miktex.org/packages/caption ) – Axel Sommerfeldt Oct 1 '15 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.